summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2017-09-28 18:37:52 +0200
committerMike Gilbert <floppym@gentoo.org>2017-09-28 13:11:00 -0400
commit729f17f718d0d3abb9eb2b702215d6b44ccc74b2 (patch)
treef54a4e8bfc0ba1e3efaefab1a99d6e23505b5cec /app-text
parentapp-i18n/mozc: Add live ebuild. (diff)
downloadgentoo-729f17f718d0d3abb9eb2b702215d6b44ccc74b2.tar.gz
gentoo-729f17f718d0d3abb9eb2b702215d6b44ccc74b2.tar.bz2
gentoo-729f17f718d0d3abb9eb2b702215d6b44ccc74b2.zip
app-text/xdvik: Call xdg_desktop_database_update() (bug #628826).
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xdvik/xdvik-22.87.03.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/app-text/xdvik/xdvik-22.87.03.ebuild b/app-text/xdvik/xdvik-22.87.03.ebuild
index 534a820e6334..760376128572 100644
--- a/app-text/xdvik/xdvik-22.87.03.ebuild
+++ b/app-text/xdvik/xdvik-22.87.03.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit eutils flag-o-matic elisp-common toolchain-funcs multilib
+inherit elisp-common eutils flag-o-matic multilib toolchain-funcs xdg-utils
DESCRIPTION="DVI previewer for X Window System"
HOMEPAGE="http://xdvi.sourceforge.net/"
@@ -92,6 +92,8 @@ src_install() {
}
pkg_postinst() {
+ xdg_desktop_database_update
+
if use emacs; then
elog "Add"
elog " (add-to-list 'load-path \"${EPREFIX}${SITELISP}/tex-utils\")"
@@ -99,3 +101,7 @@ pkg_postinst() {
elog "to your ~/.emacs file"
fi
}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}