summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-29 23:13:32 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-29 23:13:32 +0100
commit75379df2e54ae626b03169819990e40e573c08f4 (patch)
tree4ba814ee04bb306662e3eaf6ff444060e47ec1ad /app-text
parentx11-libs/libdrm: Remove old (diff)
downloadgentoo-75379df2e54ae626b03169819990e40e573c08f4.tar.gz
gentoo-75379df2e54ae626b03169819990e40e573c08f4.tar.bz2
gentoo-75379df2e54ae626b03169819990e40e573c08f4.zip
app-text/libwpg: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libwpg/Manifest1
-rw-r--r--app-text/libwpg/libwpg-0.3.1.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/app-text/libwpg/Manifest b/app-text/libwpg/Manifest
index e95d45886a2b..ee2851f53872 100644
--- a/app-text/libwpg/Manifest
+++ b/app-text/libwpg/Manifest
@@ -1,2 +1,3 @@
DIST libwpg-0.2.2.tar.xz 301000 SHA256 b49bfd77b9447534dee0d43bbdc48b4dcb09339605be21c01726243d5069a6cd SHA512 d60f8c0d29f7dbde2592d2afce1ccbe01ab10be4051d048fca0a2234f488a2764af2134ccf9ca150767d769d17dcd010433a3d977457b3a521be8f0dc628e65c WHIRLPOOL a52b90bd4c9aea2b72f615bcaaa43445dc72dad7e23f8f4667912ac3a95b729a7910b0c7608b3b47fd23a19399c72bb792432243e312d767d67c43b5c170e2f6
DIST libwpg-0.3.0.tar.xz 300244 SHA256 6f709199235f4c061c3ffe1a5112ce6430e8434e621bf7b3e3dca16114eaf224 SHA512 5715a38f7c2b69123056288576073aa36a97f971a749cffb1b176a5c4a9f7da0b6568cdf62fc4e8ebd8204b681200c1a64e5e52cfd127af986580720914f973e WHIRLPOOL db0876540fde7533f1b73b4bd1cf08c09c9d845b822fcfa7a7d375014aee597aace4c5e4662c61449cd4c09747db4013ff225acd66c33b492d6348b7243945dc
+DIST libwpg-0.3.1.tar.xz 316576 SHA256 620d888c10d7e1127d5123ff0065f1b62b86b91bac27d8ae10dcfbdb6bf4278f SHA512 5222609510857d32250e25b1108ecf4c0ce1e58fba280b7c15d400bc8963112adaa9fffa3c21087d4984ec52176d69b30bfc9460ffef978d6b0d7ccc400063b2 WHIRLPOOL c35c51b5098757a0de9a1288d185708775d4ecc2b69ad76e818df5308ec1cbcb870552d45edfe011f65aff141e12656bf98a8ce5207fc0f12ecbc9c705afb3e2
diff --git a/app-text/libwpg/libwpg-0.3.1.ebuild b/app-text/libwpg/libwpg-0.3.1.ebuild
new file mode 100644
index 000000000000..a336154985a3
--- /dev/null
+++ b/app-text/libwpg/libwpg-0.3.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit alternatives eutils
+
+DESCRIPTION="C++ library to read and parse graphics in WPG"
+HOMEPAGE="http://libwpg.sourceforge.net/libwpg.htm"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="|| ( LGPL-2.1 MPL-2.0 )"
+SLOT="0.3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="
+ app-text/libwpd:0.10[tools]
+ dev-libs/librevenge
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_configure() {
+ econf \
+ --disable-werror \
+ --program-suffix=-${SLOT} \
+ --docdir="${EPREFIX%/}/usr/share/doc/${PF}" \
+ $(use_with doc docs) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
+
+pkg_postinst() {
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
+}
+
+pkg_postrm() {
+ alternatives_auto_makesym /usr/bin/wpg2svgbatch.pl "/usr/bin/wpg2svgbatch.pl-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2svg "/usr/bin/wpg2svg-[0-9].[0-9]"
+ alternatives_auto_makesym /usr/bin/wpg2raw "/usr/bin/wpg2raw-[0-9].[0-9]"
+}