summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2017-01-24 16:53:52 +0100
committerMichael Weber <xmw@gentoo.org>2017-01-24 16:54:20 +0100
commit84d9bec0db2d23c6c38489997dcd576d1be7ee9a (patch)
tree4590a1383c1322352280a2903df3c99784f91380 /app-text
parentvirtual/perl-*: -r1 bump tweaked ebuilds for propagation (diff)
downloadgentoo-84d9bec0db2d23c6c38489997dcd576d1be7ee9a.tar.gz
gentoo-84d9bec0db2d23c6c38489997dcd576d1be7ee9a.tar.bz2
gentoo-84d9bec0db2d23c6c38489997dcd576d1be7ee9a.zip
app-text/zathura: Fix test for USE=-sqlite (bug 606870).
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zathura/files/zathura-0.3.7-tests.patch24
-rw-r--r--app-text/zathura/zathura-0.3.7.ebuild6
2 files changed, 30 insertions, 0 deletions
diff --git a/app-text/zathura/files/zathura-0.3.7-tests.patch b/app-text/zathura/files/zathura-0.3.7-tests.patch
new file mode 100644
index 000000000000..77321445c6a6
--- /dev/null
+++ b/app-text/zathura/files/zathura-0.3.7-tests.patch
@@ -0,0 +1,24 @@
+--- zathura-0.3.7/tests/Makefile
++++ zathura-0.3.7/tests/Makefile
+@@ -7,7 +7,11 @@
+ include config.mk
+
+ PROJECT = tests
+-SOURCE = tests.c $(wildcard test_*.c)
++ifneq (${WITH_SQLITE},0)
++ SOURCE = tests.c $(wildcard test_*.c)
++else
++ SOURCE = $(filter-out database-sqlite.c,tests.c $(wildcard test_*.c))
++endif
+ OBJECTS = $(addprefix ${BUILDDIR_RELEASE}/,${SOURCE:.c=.o})
+ OBJECTS_DEBUG = $(addprefix ${BUILDDIR_DEBUG}/,${SOURCE:.c=.o})
+ OBJECTS_GCOV = $(addprefix ${BUILDDIR_GCOV}/,${SOURCE:.c=.o})
+@@ -23,8 +27,6 @@
+ INCS += $(SQLITE_INC)
+ LIBS += $(SQLITE_LIB)
+ CPPFLAGS += -DWITH_SQLITE
+-else
+-SOURCE = $(filter-out database-sqlite.c,$(OSOURCE))
+ endif
+
+ ifneq ($(WITH_MAGIC),0)
diff --git a/app-text/zathura/zathura-0.3.7.ebuild b/app-text/zathura/zathura-0.3.7.ebuild
index d6a53330cbcc..543b3b036bfe 100644
--- a/app-text/zathura/zathura-0.3.7.ebuild
+++ b/app-text/zathura/zathura-0.3.7.ebuild
@@ -36,6 +36,12 @@ DEPEND="${RDEPEND}
virtual/pkgconfig
test? ( dev-libs/check )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tests.patch
+
+ epatch_user
+}
+
pkg_setup() {
myzathuraconf=(
WITH_MAGIC=$(usex magic 1 0)