summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2018-07-02 14:47:32 -0400
committerAnthony G. Basile <blueness@gentoo.org>2018-07-02 14:47:32 -0400
commitab896c4762df350f74083a91e7ec488a17c8d222 (patch)
treeab9335702b933765dcda50815ae4902d2310a5c2 /app-text
parentdev-libs/xapian-bindings: version bump to 1.4.6 (diff)
downloadgentoo-ab896c4762df350f74083a91e7ec488a17c8d222.tar.gz
gentoo-ab896c4762df350f74083a91e7ec488a17c8d222.tar.bz2
gentoo-ab896c4762df350f74083a91e7ec488a17c8d222.zip
app-text/xapian-omega: version bump to 1.4.6
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xapian-omega/Manifest1
-rw-r--r--app-text/xapian-omega/xapian-omega-1.4.6.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-text/xapian-omega/Manifest b/app-text/xapian-omega/Manifest
index 44950d3d8b86..d40f1a03d551 100644
--- a/app-text/xapian-omega/Manifest
+++ b/app-text/xapian-omega/Manifest
@@ -2,3 +2,4 @@ DIST xapian-omega-1.2.24.tar.xz 438104 BLAKE2B d2b26ad007849ac7a0a8daea919fb215c
DIST xapian-omega-1.2.25.tar.xz 440224 BLAKE2B 1e67cff0ed1796349df5da7d33c07febba2d8c79906fd98c66becd59d7d387174728551785ca42db1f69662cc157bbfc35c0e29f96958ddb76670797d9a4bcf7 SHA512 f412538cd50c82d7af28f2620c1e377afd3f03186259a145f9a37cd64d05837b7cc6f205627a3c8e4c25ec19efc2a81a6fe3a415d00b7a6f4df847d6ff2d453c
DIST xapian-omega-1.4.4.tar.xz 501712 BLAKE2B d46a463c323bf75db6d426e0ac2057f4cd6ad16ea097eeb189f00356df484af52ba0c8b09d81a0262fe833b784d2bce9df20dd3d36b6f74c17c0e7337a30e2af SHA512 927c6afe24f8a13018fcc233e874c71c0912cb6200094f7246c12b4175bc48d752312e57128a314e7674a948a50ef092dd7f2dc8910db7df8f3ccf9c44f38533
DIST xapian-omega-1.4.5.tar.xz 502820 BLAKE2B 3077a9a4fd177daa7f8470bea0b8dde25402235fee280118a90930888543b2da7821ad7d30143d04d35dccfb0de6c375231f2db4a4f4dcbaeeaf5d4e54045cfc SHA512 895da1e1a3ddf2e5e8576fd41853cc5cb7c6e4f0223a0d25f6303fd01ca26f64c8e41616d6d66b2309a4ca5763b2b20b208dbf6054f0498411f2678422c07893
+DIST xapian-omega-1.4.6.tar.xz 510012 BLAKE2B 2c6d3479fe02eb3b44ef0995b0dfc2ce47012104bc860532967f234ccb7bb2a3357337419fbf5b79b42d0f598608fe9a071edca2195e4f025fb69760091c78ec SHA512 9376145c9c7c728bf444f5891777fe946bc574a4c91ef65779aae4cd2f40c76b33cde1231f654f23de32df8a4eea4aa0c69868d269ec79fba3abad2567ffb80d
diff --git a/app-text/xapian-omega/xapian-omega-1.4.6.ebuild b/app-text/xapian-omega/xapian-omega-1.4.6.ebuild
new file mode 100644
index 000000000000..69bb116aaa81
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.4.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+SRC_URI="http://www.oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
+HOMEPAGE="https://xapian.org/"
+S="${WORKDIR}/xapian-omega-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-libs/xapian:0/30
+ dev-lang/perl
+ dev-libs/libpcre
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+src_install () {
+ emake DESTDIR="${D}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${D}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}