summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-06-30 22:22:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-06-30 22:47:32 +0200
commitdf9add78592074a5cd727447cff7cbb7e57b4de1 (patch)
treef12394df2dc6b535946aff5ec10edc1cd4d1c4bb /app-text
parentmedia-video/plasma-mediacenter: Fix cmake warning (diff)
downloadgentoo-df9add78592074a5cd727447cff7cbb7e57b4de1.tar.gz
gentoo-df9add78592074a5cd727447cff7cbb7e57b4de1.tar.bz2
gentoo-df9add78592074a5cd727447cff7cbb7e57b4de1.zip
app-text/poppler: Fix cmake warning
Closes: https://bugs.gentoo.org/659146 Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/poppler-0.66.0.ebuild2
-rw-r--r--app-text/poppler/poppler-9999.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/app-text/poppler/poppler-0.66.0.ebuild b/app-text/poppler/poppler-0.66.0.ebuild
index 5d2ce10f9354..893cc9f7e682 100644
--- a/app-text/poppler/poppler-0.66.0.ebuild
+++ b/app-text/poppler/poppler-0.66.0.ebuild
@@ -99,7 +99,6 @@ src_configure() {
-DWITH_Cairo=$(usex cairo)
-DENABLE_LIBCURL=$(usex curl)
-DENABLE_CPP=$(usex cxx)
- -DWITH_GObjectIntrospection=$(usex introspection)
-DWITH_JPEG=$(usex jpeg)
-DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
-DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
@@ -110,6 +109,7 @@ src_configure() {
-DWITH_TIFF=$(usex tiff)
-DENABLE_UTILS=$(usex utils)
)
+ use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
cmake-utils_src_configure
}
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index 5d2ce10f9354..893cc9f7e682 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -99,7 +99,6 @@ src_configure() {
-DWITH_Cairo=$(usex cairo)
-DENABLE_LIBCURL=$(usex curl)
-DENABLE_CPP=$(usex cxx)
- -DWITH_GObjectIntrospection=$(usex introspection)
-DWITH_JPEG=$(usex jpeg)
-DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
-DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
@@ -110,6 +109,7 @@ src_configure() {
-DWITH_TIFF=$(usex tiff)
-DENABLE_UTILS=$(usex utils)
)
+ use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
cmake-utils_src_configure
}