summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-07-03 11:23:46 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-07-03 11:28:50 +0000
commit9095dbf689fe7211f775b1762e8ac11b2c015819 (patch)
tree0ab44a6ed82cdc29167b01d8b786de225999c8e3 /app-vim/autoalign
parentapp-arch/torrentzip: Clean up old. (diff)
downloadgentoo-9095dbf689fe7211f775b1762e8ac11b2c015819.tar.gz
gentoo-9095dbf689fe7211f775b1762e8ac11b2c015819.tar.bz2
gentoo-9095dbf689fe7211f775b1762e8ac11b2c015819.zip
app-vim/autoalign: Stable for amd64. Retroactively mark stable for the remaining arches using the ALLARCHES policy.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-vim/autoalign')
-rw-r--r--app-vim/autoalign/autoalign-14.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/app-vim/autoalign/autoalign-14.ebuild b/app-vim/autoalign/autoalign-14.ebuild
index 3f0cf76d76be..31a0b14293ab 100644
--- a/app-vim/autoalign/autoalign-14.ebuild
+++ b/app-vim/autoalign/autoalign-14.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
+
EAPI=5
inherit vim-plugin
@@ -8,7 +9,7 @@ inherit vim-plugin
DESCRIPTION="vim plugin: automatically align bib, c, c++, tex and vim code"
HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=884"
LICENSE="vim"
-KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+KEYWORDS="alpha amd64 ia64 mips ppc sparc x86"
IUSE=""
if [[ ${PV} != 9999* ]] ; then
@@ -17,7 +18,8 @@ if [[ ${PV} != 9999* ]] ; then
fi
DEPEND="app-arch/xz-utils"
-RDEPEND=">=app-vim/align-30
+RDEPEND="
+ >=app-vim/align-30
>=app-vim/cecutil-4"
VIM_PLUGIN_HELPFILES="autoalign"
@@ -26,5 +28,5 @@ VIM_PLUGIN_MESSAGES="filetype"
src_prepare() {
# Don't use the cecutil.vim included in the tarball, use the one
# provided by app-vim/cecutil instead.
- rm plugin/cecutil.vim
+ rm plugin/cecutil.vim || die
}