summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-09-02 15:18:04 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-09-02 15:18:04 +0200
commit086fcf7efc0a1d9dd26a6beeb9356c0665dfe68c (patch)
treed672db1bab2ff1c8f100f0ab2b449166051148f4 /app-vim/ebnf-syntax
parentapp-vim/cmdalias: EAPI 6 bump. (diff)
downloadgentoo-086fcf7efc0a1d9dd26a6beeb9356c0665dfe68c.tar.gz
gentoo-086fcf7efc0a1d9dd26a6beeb9356c0665dfe68c.tar.bz2
gentoo-086fcf7efc0a1d9dd26a6beeb9356c0665dfe68c.zip
app-vim/ebnf-syntax: EAPI 6 bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-vim/ebnf-syntax')
-rw-r--r--app-vim/ebnf-syntax/ebnf-syntax-1.1-r2.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/ebnf-syntax/ebnf-syntax-1.1-r2.ebuild b/app-vim/ebnf-syntax/ebnf-syntax-1.1-r2.ebuild
new file mode 100644
index 000000000000..8dd9868a4406
--- /dev/null
+++ b/app-vim/ebnf-syntax/ebnf-syntax-1.1-r2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: EBNF (ISO/IEC 14997) file syntax highlighting"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=545"
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting for EBNF (ISO/IEC 14997) files."
+
+src_prepare() {
+ default
+
+ # don't use hi link, bug #101799.
+ sed -i -e 's,hi link,hi def link,' syntax/ebnf.vim || die "sed failed"
+}