summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/nerdtree
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/nerdtree')
-rw-r--r--app-vim/nerdtree/Manifest2
-rw-r--r--app-vim/nerdtree/metadata.xml5
-rw-r--r--app-vim/nerdtree/nerdtree-4.1.0.ebuild22
-rw-r--r--app-vim/nerdtree/nerdtree-4.2.0.ebuild15
4 files changed, 44 insertions, 0 deletions
diff --git a/app-vim/nerdtree/Manifest b/app-vim/nerdtree/Manifest
new file mode 100644
index 000000000000..03430e3e2a90
--- /dev/null
+++ b/app-vim/nerdtree/Manifest
@@ -0,0 +1,2 @@
+DIST nerdtree-4.1.0.zip 44645 SHA256 34fd5a007a89b78601b6dfa99866c3214a42c46349505a7b1c62768eb4a1ff01 SHA512 d26382d6e1562f7f190b42499acf2417d9a4dfb64039f4673cca578123002e88986a82c3f2e9835970b73656566ef96c9fdd0b12bd68f6aa9c4677d8c3e00441 WHIRLPOOL 1b54c51c781db856c3a03d892ca0755bce4a4869a91c16a5baf82c72a43f754264ee4d764eb551e952fdf36cd81f00debc7841ace2a21aac0f26a47e8afa422e
+DIST nerdtree-4.2.0.tar.bz2 36943 SHA256 6504080b52be5b8a17650d12237f516fe5e44ed20b6da9520d2d69189f3be2c5 SHA512 dd8886ee1671e5290a0a094630433979bedb7a5e1f0fdab0c8d6d93e85216bd84dbf12d33be4f249886b6be4e04ae7d6041e290c50fa2e5044035aee4eff8e06 WHIRLPOOL 9a285b4d9a2d1ca1804c3d5c0f3959762d7c391636e1f3eb10198421645ccdf2db1058a9c12f49949e73be58f3a9fb4219a0d0328381f60b19cd9460c47a7ec9
diff --git a/app-vim/nerdtree/metadata.xml b/app-vim/nerdtree/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/nerdtree/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>
diff --git a/app-vim/nerdtree/nerdtree-4.1.0.ebuild b/app-vim/nerdtree/nerdtree-4.1.0.ebuild
new file mode 100644
index 000000000000..77866e15f42e
--- /dev/null
+++ b/app-vim/nerdtree/nerdtree-4.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+VIM_PLUGIN_VIM_VERSION="7.0"
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: A tree explorer plugin for navigating the filesystem"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1658"
+SRC_URI="http://www.vim.org/scripts/download_script.php?src_id=11834 -> ${P}.zip"
+LICENSE="WTFPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"
+
+VIM_PLUGIN_HELPFILES="NERD_tree"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
diff --git a/app-vim/nerdtree/nerdtree-4.2.0.ebuild b/app-vim/nerdtree/nerdtree-4.2.0.ebuild
new file mode 100644
index 000000000000..050de913862a
--- /dev/null
+++ b/app-vim/nerdtree/nerdtree-4.2.0.ebuild
@@ -0,0 +1,15 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: A tree explorer plugin for navigating the filesystem"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=1658"
+LICENSE="WTFPL-2"
+KEYWORDS="amd64 x86 ~x64-macos"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="NERD_tree"