summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-08-20 18:26:01 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-20 18:26:11 +0200
commit38eb7ec3b95030e163f50aab03185403e6c64451 (patch)
tree6064f6691f1657b9671502fec414bcbc00cc9e41 /app-vim/pydoc
parentapp-forensics/quickfuzz: tweak for derive-2.6 (diff)
downloadgentoo-38eb7ec3b95030e163f50aab03185403e6c64451.tar.gz
gentoo-38eb7ec3b95030e163f50aab03185403e6c64451.tar.bz2
gentoo-38eb7ec3b95030e163f50aab03185403e6c64451.zip
app-vim/pydoc: port to python-single-r1.
Gentoo-Bug: https://bugs.gentoo.org/615910 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-vim/pydoc')
-rw-r--r--app-vim/pydoc/pydoc-2.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/pydoc/pydoc-2.0-r1.ebuild b/app-vim/pydoc/pydoc-2.0-r1.ebuild
new file mode 100644
index 000000000000..a545995d0321
--- /dev/null
+++ b/app-vim/pydoc/pydoc-2.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit vim-plugin python-single-r1
+
+DESCRIPTION="vim plugin: integrates python documentation view and search tool"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=910 https://github.com/fs111/pydoc.vim"
+SRC_URI="https://github.com/fs111/${PN}.vim/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+src_unpack() {
+ default
+ mv * "${P}" || die
+}