summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/vim-latex/vim-latex-1.8.23.20130116.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/vim-latex/vim-latex-1.8.23.20130116.ebuild')
-rw-r--r--app-vim/vim-latex/vim-latex-1.8.23.20130116.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-vim/vim-latex/vim-latex-1.8.23.20130116.ebuild b/app-vim/vim-latex/vim-latex-1.8.23.20130116.ebuild
new file mode 100644
index 000000000000..bb75db87c7b7
--- /dev/null
+++ b/app-vim/vim-latex/vim-latex-1.8.23.20130116.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit vim-plugin versionator python-single-r1
+
+MY_REV="788-git2ef9956"
+MY_P="${PN}-$( replace_version_separator 3 - ).${MY_REV}"
+
+DESCRIPTION="vim plugin: a comprehensive set of tools to view, edit and compile LaTeX documents"
+HOMEPAGE="http://vim-latex.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="vim"
+KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE="html python"
+
+RDEPEND="|| ( app-editors/vim[python?] app-editors/gvim[python?] )
+ virtual/latex-base"
+
+S=${WORKDIR}/${MY_P}
+
+VIM_PLUGIN_HELPFILES="latex-suite.txt latex-suite-quickstart.txt latexhelp.txt imaps.txt"
+
+src_prepare() {
+ # The makefiles do weird stuff, including running the svn command
+ rm Makefile Makefile.in || die "rm Makefile Makefile.in failed"
+}
+
+src_install() {
+ use html && dohtml -r doc/
+
+ # Don't mess up vim's doc dir with random files
+ mv doc mydoc || die
+ mkdir doc || die
+ mv mydoc/*.txt doc/ || die
+ rm -rf mydoc || die
+
+ # Don't install buggy tags scripts, use ctags instead
+ rm latextags ltags || die
+
+ vim-plugin_src_install
+
+ # Use executable permissions (bug #352403)
+ fperms a+x /usr/share/vim/vimfiles/ftplugin/latex-suite/outline.py
+
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ vim-plugin_pkg_postinst
+ elog
+ elog "To use the vim-latex plugin add:"
+ elog " filetype plugin on"
+ elog ' set grepprg=grep\ -nH\ $*'
+ elog " let g:tex_flavor='latex'"
+ elog "to your ~/.vimrc-file"
+ elog
+}