summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-11-06 00:34:45 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-11-06 00:35:57 +0100
commit3eb669ffb0a423507e71b746614dd5a40f1e545e (patch)
tree03cf2eeb9f6662179c4d8bbbe5c0849646c10cb4 /app-vim/vim2hs
parentdev-php/PEAR-PEAR: remove unused PEAR-PEAR-1.10.3-r2.ebuild. (diff)
downloadgentoo-3eb669ffb0a423507e71b746614dd5a40f1e545e.tar.gz
gentoo-3eb669ffb0a423507e71b746614dd5a40f1e545e.tar.bz2
gentoo-3eb669ffb0a423507e71b746614dd5a40f1e545e.zip
app-vim/vim2hs: new package.
vim2hs is a collection of vimscripts for Haskell development. Closes: https://bugs.gentoo.org/476450 Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-vim/vim2hs')
-rw-r--r--app-vim/vim2hs/Manifest1
-rw-r--r--app-vim/vim2hs/metadata.xml11
-rw-r--r--app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild31
3 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/vim2hs/Manifest b/app-vim/vim2hs/Manifest
new file mode 100644
index 000000000000..b02f4f636772
--- /dev/null
+++ b/app-vim/vim2hs/Manifest
@@ -0,0 +1 @@
+DIST vim2hs-0.1_p20171106.tar.gz 259627 SHA256 7190ad8b7f205331d6485b584acfdca6c0b45aed4e5242e482110d17871bc728 SHA512 835ea1344f055af06843a327bf7294ae9fe0e735455b3c21d4fba56eab75f19b578ff8cd962f6527efee0e0f89084c9c2cd86d3944e0ac35b89b33a6047df4a0 WHIRLPOOL 40caa6f1fccd6b344e8b808c99387c4ecceec935fce219ba42587e59b9a390fc23e99c8bbbf7e7933a3c95975dc773c0be5363aee6ebaf6e4ac1b3131c891711
diff --git a/app-vim/vim2hs/metadata.xml b/app-vim/vim2hs/metadata.xml
new file mode 100644
index 000000000000..cf984477fc49
--- /dev/null
+++ b/app-vim/vim2hs/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">dag/vim2hs</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild b/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild
new file mode 100644
index 000000000000..4d8504e4b3a0
--- /dev/null
+++ b/app-vim/vim2hs/vim2hs-0.1_p20171106.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+# Commit Date: 16 Apr 2014
+COMMIT="f2afd55704bfe0a2d66e6b270d247e9b8a7b1664"
+
+DESCRIPTION="vim plugin: collection of vimscripts for Haskell development"
+HOMEPAGE="https://github.com/dag/vim2hs"
+SRC_URI="https://github.com/dag/vim2hs/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/ghc"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_compile() { :; }
+
+src_install() {
+ # We want a stripped-down version of these.
+ local f
+ for f in screenshots/*; do
+ bzip2 -9 "${f}" || die
+ done
+ vim-plugin_src_install
+}