summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-17 17:07:01 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-17 17:09:24 -0400
commit805d270a2d2ef1096d73ddc94a4d81dbf9005293 (patch)
tree26f8334516accd765c03783af9aed7464a139f52 /app-vim/vimagit
parentapp-vim/gitv: version bump to 1.3.1 (diff)
downloadgentoo-805d270a2d2ef1096d73ddc94a4d81dbf9005293.tar.gz
gentoo-805d270a2d2ef1096d73ddc94a4d81dbf9005293.tar.bz2
gentoo-805d270a2d2ef1096d73ddc94a4d81dbf9005293.zip
app-vim/vimagit: version bump to 1.7.2
Diffstat (limited to 'app-vim/vimagit')
-rw-r--r--app-vim/vimagit/Manifest1
-rw-r--r--app-vim/vimagit/vimagit-1.7.2.ebuild25
-rw-r--r--app-vim/vimagit/vimagit-9999.ebuild5
3 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/vimagit/Manifest b/app-vim/vimagit/Manifest
index 4c24c28e67cd..7333c82daea3 100644
--- a/app-vim/vimagit/Manifest
+++ b/app-vim/vimagit/Manifest
@@ -1 +1,2 @@
DIST vimagit-1.7.1.tar.gz 35302 SHA256 96b61af002f31f1a73bb67ced06e8aced696e6c9539f0d5be9f25c469f1a16c4 SHA512 8ce2959c135da90b880ccdcd66e71661c7908f250d47a24ede025762a6e9422cebcf8fd516bf99e475605f4278e232713c66293781ceb95f47a22031e9260a71 WHIRLPOOL 8331ab3736017b8930934e8661002edf3d24efe92032f7e0656338ae44f21b02037a9673f91e6733b4ef09b15a75b413419b91a656a54224317d5aba24aa1f9d
+DIST vimagit-1.7.2.tar.gz 37398 SHA256 bac4b3b3e91815699ae34374874e2fd181f31108f8dd4be6c434d79c8eb462d5 SHA512 8b825da4b411732db022b1a3f25f6f779ba5e58df5ca4d404e985b16a4811f911c626674f1a7f4a285d78369f4c7ad3a33b7ffa2b50f1a4a94372a3c5fb29a15 WHIRLPOOL e1376e9fd3652812a963eb94840022a513ef2ef563ad81329e601db956c40ccdb18d2ecfc2d3995aef4648768ade73883c9c0f4cc35b712e102e18ec812aba24
diff --git a/app-vim/vimagit/vimagit-1.7.2.ebuild b/app-vim/vimagit/vimagit-1.7.2.ebuild
new file mode 100644
index 000000000000..5e291f76fe70
--- /dev/null
+++ b/app-vim/vimagit/vimagit-1.7.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jreybert/vimagit.git"
+else
+ SRC_URI="https://github.com/jreybert/vimagit/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: ease your git workflow within vim"
+HOMEPAGE="https://github.com/jreybert/vimagit"
+LICENSE="vim"
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ rm _config.yml || die
+ default
+}
diff --git a/app-vim/vimagit/vimagit-9999.ebuild b/app-vim/vimagit/vimagit-9999.ebuild
index 1583759b0cc2..5e291f76fe70 100644
--- a/app-vim/vimagit/vimagit-9999.ebuild
+++ b/app-vim/vimagit/vimagit-9999.ebuild
@@ -18,3 +18,8 @@ LICENSE="vim"
VIM_PLUGIN_HELPFILES="${PN}"
RDEPEND="dev-vcs/git"
+
+src_prepare() {
+ rm _config.yml || die
+ default
+}