summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2021-05-24 11:36:15 +0300
committerMichał Górny <mgorny@gentoo.org>2021-05-24 20:52:14 +0200
commit0687b878a88268793695044fbd754ff8988b1fe6 (patch)
treed9f329c80c79e3eb63b4175369544463a5a71257 /app-vim
parentapp-vim/vimpython: bump to python 3.9, 3.10 (diff)
downloadgentoo-0687b878a88268793695044fbd754ff8988b1fe6.tar.gz
gentoo-0687b878a88268793695044fbd754ff8988b1fe6.tar.bz2
gentoo-0687b878a88268793695044fbd754ff8988b1fe6.zip
app-vim/jedi: bump to python 3.9
Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/jedi/jedi-0.10.0.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/app-vim/jedi/jedi-0.10.0.ebuild b/app-vim/jedi/jedi-0.10.0.ebuild
index ef127090588..7b566e30703 100644
--- a/app-vim/jedi/jedi-0.10.0.ebuild
+++ b/app-vim/jedi/jedi-0.10.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..9} )
inherit vim-plugin python-single-r1
@@ -19,7 +19,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
${PYTHON_DEPS}
- $(python_gen_cond_dep 'dev-python/jedi[${PYTHON_MULTI_USEDEP}]')
+ $(python_gen_cond_dep 'dev-python/jedi[${PYTHON_USEDEP}]')
app-editors/vim[python]"
BDEPEND="${PYTHON_DEPS}
test? ( dev-python/pytest )"
@@ -32,10 +32,6 @@ RESTRICT="test"
# Makefile tries hard to call tests so let's silence this phase.
src_compile() { :; }
-src_install() {
- vim-plugin_src_install
-}
-
src_test() {
- pytest -vv || die
+ epytest
}