summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-12-21 20:04:44 -0600
committerTim Harder <radhermit@gentoo.org>2018-12-21 20:22:09 -0600
commit55d217a12c89c5fb04e74773648139274f40f20d (patch)
treeb933d20e486fb645313092b0963d5c319eaf713e /app-vim
parentprofiles/profiles.desc: add steev as co-maintainer of default/linux/arm64/17.... (diff)
downloadgentoo-55d217a12c89c5fb04e74773648139274f40f20d.tar.gz
gentoo-55d217a12c89c5fb04e74773648139274f40f20d.tar.bz2
gentoo-55d217a12c89c5fb04e74773648139274f40f20d.zip
app-vim/airline: version bump to 0.10
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/airline/Manifest1
-rw-r--r--app-vim/airline/airline-0.10.ebuild29
-rw-r--r--app-vim/airline/airline-9999.ebuild4
3 files changed, 32 insertions, 2 deletions
diff --git a/app-vim/airline/Manifest b/app-vim/airline/Manifest
index 3a571cb64a99..5b4d315532a7 100644
--- a/app-vim/airline/Manifest
+++ b/app-vim/airline/Manifest
@@ -1 +1,2 @@
+DIST airline-0.10.tar.gz 86724 BLAKE2B b0019b07b188039a9a91d83bc240e6b2eedaf9d798483f03d252b57269c0cbbc58625b3d14e36a3caaa6fd35b65716d67a967a38511806d76bc7e76192086349 SHA512 94c87800b793d575d8e1fbf2971cc97e89aae4a6bd9581aee628d4e4f2d9e74df427fcc91b17908819b5f4793c72a9d0a827d5046d80918a52ef8e090ff2cae6
DIST airline-0.9.tar.gz 72660 BLAKE2B d6c9762d8140b2a88a001b9ea3ae62c3c9147ccf3db90146d7fded8dcbc6062bf97c0725baa79db9d7bfe0eeaa5dc00ddfabde8ed1b9aec7f5aa24c41b11d1f2 SHA512 f3fd03c7ab6603eee6e892a1b88888d72fc43cf0a8582ad7e65152cddebb0d14be3a805529fa5467fc82e040cce2616f1693bf294c892c0849d9fb51cbbd04ec
diff --git a/app-vim/airline/airline-0.10.ebuild b/app-vim/airline/airline-0.10.ebuild
new file mode 100644
index 000000000000..5c0506370c59
--- /dev/null
+++ b/app-vim/airline/airline-0.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+if [[ ${PV} != 9999* ]] ; then
+ MY_PN=vim-${PN}
+ MY_P=${MY_PN}-${PV}
+ SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S=${WORKDIR}/${MY_P}
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/vim-airline/vim-airline.git"
+fi
+
+DESCRIPTION="vim plugin: lean & mean statusline for vim that's light as air"
+HOMEPAGE="https://github.com/vim-airline/vim-airline/ https://www.vim.org/scripts/script.php?script_id=4661"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm -r t Gemfile Rakefile LICENSE README* || die
+}
diff --git a/app-vim/airline/airline-9999.ebuild b/app-vim/airline/airline-9999.ebuild
index 2b0d045e241b..5c0506370c59 100644
--- a/app-vim/airline/airline-9999.ebuild
+++ b/app-vim/airline/airline-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit vim-plugin