summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-08-22 10:55:28 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-08-22 10:56:28 +0200
commitce00a82679eed3e5773f68587d5f6ab7bd3cc84b (patch)
tree15f268932c299ada8d432bb0541c94c5268a4f6b /app-vim
parentdev-python/argcomplete: Clean up old. (diff)
downloadgentoo-ce00a82679eed3e5773f68587d5f6ab7bd3cc84b.tar.gz
gentoo-ce00a82679eed3e5773f68587d5f6ab7bd3cc84b.tar.bz2
gentoo-ce00a82679eed3e5773f68587d5f6ab7bd3cc84b.zip
app-vim/tasklist: Add tasklist vim plugin to the tree.
Gentoo-Bug: https://bugs.gentoo.org/336437 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/tasklist/Manifest1
-rw-r--r--app-vim/tasklist/metadata.xml12
-rw-r--r--app-vim/tasklist/tasklist-1.0.1.ebuild20
3 files changed, 33 insertions, 0 deletions
diff --git a/app-vim/tasklist/Manifest b/app-vim/tasklist/Manifest
new file mode 100644
index 000000000000..7a55c61fd856
--- /dev/null
+++ b/app-vim/tasklist/Manifest
@@ -0,0 +1 @@
+DIST tasklist-1.0.1.tar.gz 4066 SHA256 70c676e71d3fe6f98ff99b2ad9df64ed8b7ae2f526dd83f5fe938e521170c603 SHA512 623ec5b147e485abe3e246796a6ed67dd8325ef37708e589c4568897da10ba70076eb5dffd9fb9333fc29d045c316cf382950de13f616873334fc734875600b9 WHIRLPOOL 4d59eaad371860a2a3d8fff861ee663b4fbcb40e80e3f14d29c386d64938b063228b12e13a67869d7f1ef24736c75bb652215add39c749b370f75c8ed74472ba
diff --git a/app-vim/tasklist/metadata.xml b/app-vim/tasklist/metadata.xml
new file mode 100644
index 000000000000..8fafbfec1948
--- /dev/null
+++ b/app-vim/tasklist/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/tasklist/tasklist-1.0.1.ebuild b/app-vim/tasklist/tasklist-1.0.1.ebuild
new file mode 100644
index 000000000000..958d173623c0
--- /dev/null
+++ b/app-vim/tasklist/tasklist-1.0.1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="Highlight FIXME/TODO/CUSTOM keywords in a separate list"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2607"
+SRC_URI="https://github.com/vim-scripts/${PN}.vim/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_unpack() {
+ default
+ mv vim-* "${P}" || die
+}