summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-12-12 12:06:35 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-12-12 12:07:12 +0100
commit774e50789bf3506a2cf7237bff3358ea75e548a5 (patch)
treed7f9a9f52151a2e529a218739bbae7492d18c19f /dev-cpp/antlr-cpp
parentdev-vcs/git: Stable for amd64 and x86 (bug #601984). (diff)
downloadgentoo-774e50789bf3506a2cf7237bff3358ea75e548a5.tar.gz
gentoo-774e50789bf3506a2cf7237bff3358ea75e548a5.tar.bz2
gentoo-774e50789bf3506a2cf7237bff3358ea75e548a5.zip
dev-cpp/antlr-cpp: version bump.
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-cpp/antlr-cpp')
-rw-r--r--dev-cpp/antlr-cpp/Manifest1
-rw-r--r--dev-cpp/antlr-cpp/antlr-cpp-3.5.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/dev-cpp/antlr-cpp/Manifest b/dev-cpp/antlr-cpp/Manifest
index 220142fcadb7..b9482fd08ba4 100644
--- a/dev-cpp/antlr-cpp/Manifest
+++ b/dev-cpp/antlr-cpp/Manifest
@@ -1 +1,2 @@
DIST antlr-2.7.7.tar.gz 1816180 SHA256 853aeb021aef7586bda29e74a6b03006bcb565a755c86b66032d8ec31b67dbb9 SHA512 faa72d2ddcba434ef1233e70c1549e63eba67c00793966322e821cf7f015cccb804448cb92d8fbef0429f59928fad65ec954f8ffbda0acbb8e983de0806d349d WHIRLPOOL def5ac0ddfe5a65f9f7d5489d039048c5d630b46cd5626593bd12e9b393d5ec26884f90b013bcdf58511e26abbf06e0d7b3789a11298b017f7e70af2ec8dde4a
+DIST antlr-cpp-3.5.2.tar.gz 6927126 SHA256 529baf7d11f06b773543e25271c1a6e1735d2f8061f4866d1ea5c99a5d71ee1f SHA512 e2a0520093fb2a77dcd9d44f26a9fdd612dceaffb398c53b2b8cd29f4630830647ede29e8dd55b434cb2c165b0fd1d77968ec6e6de0798f14d9cdfd9e6fccd99 WHIRLPOOL a3a2bf81cc91a332725a4ce15dcccf10df5395b27a521656b1f3e80fed10197edc132fa2a8b9a259b2ee603320492b4b1f664692a967fdfdbb574d919b9aa20e
diff --git a/dev-cpp/antlr-cpp/antlr-cpp-3.5.2.ebuild b/dev-cpp/antlr-cpp/antlr-cpp-3.5.2.ebuild
new file mode 100644
index 000000000000..24195f44eb2b
--- /dev/null
+++ b/dev-cpp/antlr-cpp/antlr-cpp-3.5.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=6
+
+MY_PN="${PN%-cpp}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="The ANTLR 3 C++ Runtime"
+HOMEPAGE="http://www.antlr3.org/"
+SRC_URI="https://github.com/${MY_PN}/${MY_PN}3/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+SLOT="3.5"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${MY_PN}3-${PV}"
+
+RDEPEND="!dev-java/antlr:0[cxx]"
+
+src_install() {
+ insinto /usr/include/antlr3
+ doins "${S}"/runtime/Cpp/include/*
+}