summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-02 23:06:16 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-02 23:19:18 +0200
commit31985d4938f7ab6990bc4fc2c2960e8923b4d900 (patch)
tree625b8434a247a4cbc581e605fbb7475f6bc190b1 /dev-cpp/catch/catch-9999.ebuild
parentapp-cdr/mirage2iso: Bump to EAPI 6, clean up (diff)
downloadgentoo-31985d4938f7ab6990bc4fc2c2960e8923b4d900.tar.gz
gentoo-31985d4938f7ab6990bc4fc2c2960e8923b4d900.tar.bz2
gentoo-31985d4938f7ab6990bc4fc2c2960e8923b4d900.zip
dev-cpp/catch: Avoid unnecessary IUSE=test
Diffstat (limited to 'dev-cpp/catch/catch-9999.ebuild')
-rw-r--r--dev-cpp/catch/catch-9999.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/dev-cpp/catch/catch-9999.ebuild b/dev-cpp/catch/catch-9999.ebuild
index ee8fefd8da7c..8fb27fb7cc50 100644
--- a/dev-cpp/catch/catch-9999.ebuild
+++ b/dev-cpp/catch/catch-9999.ebuild
@@ -14,21 +14,18 @@ SRC_URI=""
LICENSE="Boost-1.0"
SLOT="0"
KEYWORDS=""
-IUSE="test"
+IUSE=""
CMAKE_USE_DIR=${S}/projects/CMake
-src_configure() {
- # CMake is only used to build & run tests
- use test && cmake-utils_src_configure
-}
-
-src_compile() {
- use test && cmake-utils_src_compile
-}
+# CMake is only used to build & run tests, so override phases
+src_configure() { :; }
+src_compile() { :; }
src_test() {
- use test && cmake-utils_src_test
+ cmake-utils_src_configure
+ cmake-utils_src_compile
+ cmake-utils_src_test
}
src_install() {