summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2018-12-13 15:07:56 +0100
committerDavid Seifert <soap@gentoo.org>2018-12-13 15:07:56 +0100
commitc06262da68dee7db70741d67eb60e354904a66b0 (patch)
treeee3a390c7059383e2b0bc06f93281b6c6093c63a /dev-cpp/catch
parentsci-biology/bamtools: Bump to EAPI 7 (diff)
downloadgentoo-c06262da68dee7db70741d67eb60e354904a66b0.tar.gz
gentoo-c06262da68dee7db70741d67eb60e354904a66b0.tar.bz2
gentoo-c06262da68dee7db70741d67eb60e354904a66b0.zip
dev-cpp/catch: Bump to EAPI 7
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'dev-cpp/catch')
-rw-r--r--dev-cpp/catch/catch-1.12.2.ebuild3
-rw-r--r--dev-cpp/catch/catch-1.9999.ebuild3
-rw-r--r--dev-cpp/catch/catch-2.5.0.ebuild6
-rw-r--r--dev-cpp/catch/catch-9999.ebuild19
4 files changed, 18 insertions, 13 deletions
diff --git a/dev-cpp/catch/catch-1.12.2.ebuild b/dev-cpp/catch/catch-1.12.2.ebuild
index f67c3c4193b5..f8b78e009959 100644
--- a/dev-cpp/catch/catch-1.12.2.ebuild
+++ b/dev-cpp/catch/catch-1.12.2.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
inherit cmake-utils
if [[ ${PV} == *9999 ]]; then
diff --git a/dev-cpp/catch/catch-1.9999.ebuild b/dev-cpp/catch/catch-1.9999.ebuild
index f67c3c4193b5..f8b78e009959 100644
--- a/dev-cpp/catch/catch-1.9999.ebuild
+++ b/dev-cpp/catch/catch-1.9999.ebuild
@@ -1,9 +1,8 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
inherit cmake-utils
if [[ ${PV} == *9999 ]]; then
diff --git a/dev-cpp/catch/catch-2.5.0.ebuild b/dev-cpp/catch/catch-2.5.0.ebuild
index 8249b5cedb5b..5318b054d396 100644
--- a/dev-cpp/catch/catch-2.5.0.ebuild
+++ b/dev-cpp/catch/catch-2.5.0.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
inherit cmake-utils python-any-r1
if [[ ${PV} == *9999 ]]; then
@@ -27,7 +26,7 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
-DEPEND="test? ( ${PYTHON_DEPS} )"
+BDEPEND="test? ( ${PYTHON_DEPS} )"
pkg_setup() {
use test && python-any-r1_pkg_setup
@@ -37,7 +36,6 @@ src_configure() {
local mycmakeargs=(
-DCATCH_ENABLE_WERROR=OFF
-DBUILD_TESTING=$(usex test)
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
)
use test &&
mycmakeargs+=(-DPYTHON_EXECUTABLE="${PYTHON}")
diff --git a/dev-cpp/catch/catch-9999.ebuild b/dev-cpp/catch/catch-9999.ebuild
index d7763c4ccaa9..5318b054d396 100644
--- a/dev-cpp/catch/catch-9999.ebuild
+++ b/dev-cpp/catch/catch-9999.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-: ${CMAKE_MAKEFILE_GENERATOR:=ninja}
-inherit cmake-utils
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit cmake-utils python-any-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -25,11 +26,19 @@ SLOT="0"
IUSE="test"
RESTRICT="!test? ( test )"
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
src_configure() {
local mycmakeargs=(
-DCATCH_ENABLE_WERROR=OFF
-DBUILD_TESTING=$(usex test)
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
)
+ use test &&
+ mycmakeargs+=(-DPYTHON_EXECUTABLE="${PYTHON}")
+
cmake-utils_src_configure
}