summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-02-25 16:51:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-02-25 16:55:29 +0100
commit26ef084df3e43be1b257bfc99772ce75b7eea38c (patch)
tree19abbcebb2f2f7d1b510f9368d268233d44d4dcb /dev-cpp/eigen
parentdev-qt/qtscript: Fix build with >=GCC-8.3.0 (diff)
downloadgentoo-26ef084df3e43be1b257bfc99772ce75b7eea38c.tar.gz
gentoo-26ef084df3e43be1b257bfc99772ce75b7eea38c.tar.bz2
gentoo-26ef084df3e43be1b257bfc99772ce75b7eea38c.zip
dev-cpp/eigen: Drop old
Closes: https://bugs.gentoo.org/577262 Closes: https://bugs.gentoo.org/466360 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-cpp/eigen')
-rw-r--r--dev-cpp/eigen/Manifest2
-rw-r--r--dev-cpp/eigen/eigen-3.2.8-r2.ebuild112
-rw-r--r--dev-cpp/eigen/eigen-3.3.5-r1.ebuild101
-rw-r--r--dev-cpp/eigen/files/eigen-3.2.7-adaolc-backport.patch40
-rw-r--r--dev-cpp/eigen/files/eigen-3.2.7-pastix-5.2-backport.patch42
-rw-r--r--dev-cpp/eigen/files/eigen-3.3.5-fix-prototype.patch19
6 files changed, 0 insertions, 316 deletions
diff --git a/dev-cpp/eigen/Manifest b/dev-cpp/eigen/Manifest
index 7f25631de667..81084cf0e54e 100644
--- a/dev-cpp/eigen/Manifest
+++ b/dev-cpp/eigen/Manifest
@@ -1,3 +1 @@
-DIST eigen-3.2.8.tar.bz2 1161201 BLAKE2B 35bace5138f601e73d56412e87bf591ef2f96778050b0a2a4fc8f1e75f02498fb4eb80bf79988dd4bd6b985945a122d44581ccedd925f398f7d282790da06385 SHA512 53c27ba530c985dfef52188e03273eeef33abbc67e3f150cacd3371c8b9ddbd399228730595821c4c56c061d109cf509266c1dab2b8a7c730902cbd6fb18c100
-DIST eigen-3.3.5.tar.bz2 1663467 BLAKE2B 7f4b6339f8cea815004057361734e53129b5bde45c9c310eab87f0aa20da90e46dd67359e669f8b36477339df7bd7c8bd8eb18baaf0f1a779372ec3623c50aca SHA512 740ed41862c1e422a751b205513754e9c7bd04cc8ad4e3b08e2ccd1c1d30dea43a90896bc8eecd0cb4253b4adf803a814ddd48d6166fb5a53f507cf3e6940a38
DIST eigen-3.3.7.tar.bz2 1665168 BLAKE2B 544d35d1c7a4125affa094c6aa372c2aeca4e99bc60c496ff393d538c1c467b454491a772121450e3a1a43a582d073b4b7584918354d0b9175121fde88947c4b SHA512 c12bfd034d0a1112bf2df3f773ad98f36b2b53fbbfceac5f143ee1793322746fb8a6546d7db7da2a1000da6a535bd8cea0c4125b549afc90a6570743b02dcf3d
diff --git a/dev-cpp/eigen/eigen-3.2.8-r2.ebuild b/dev-cpp/eigen/eigen-3.2.8-r2.ebuild
deleted file mode 100644
index 91ae1429ee00..000000000000
--- a/dev-cpp/eigen/eigen-3.2.8-r2.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-FORTRAN_NEEDED="test"
-
-inherit cmake-utils fortran-2
-
-DESCRIPTION="C++ template library for linear algebra"
-HOMEPAGE="http://eigen.tuxfamily.org/"
-SRC_URI="https://bitbucket.org/eigen/eigen/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
-
-LICENSE="LGPL-2 GPL-3"
-SLOT="3"
-KEYWORDS="~alpha amd64 ~arm ~ia64 ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="altivec debug doc openmp test"
-IUSE+=" cpu_flags_x86_sse2"
-IUSE+=" cpu_flags_x86_sse3"
-IUSE+=" cpu_flags_x86_sse4_1"
-IUSE+=" cpu_flags_x86_sse4_2"
-IUSE+=" cpu_flags_x86_ssse3"
-#IUSE+=" cpu_flags_x86_x87"
-RESTRICT="!test? ( test )"
-
-RDEPEND="!dev-cpp/eigen:0"
-DEPEND="
- doc? ( app-doc/doxygen[dot,latex] )
- test? (
- dev-libs/gmp:0
- dev-libs/mpfr:0
- media-libs/freeglut
- media-libs/glew
- sci-libs/adolc
- sci-libs/cholmod
- sci-libs/fftw:3.0
- sci-libs/pastix
- sci-libs/umfpack
- sci-libs/scotch
- sci-libs/spqr
- sci-libs/superlu
- virtual/opengl
- virtual/pkgconfig
- )
- "
-# Missing:
-# METIS-5
-# GOOGLEHASH
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.2.7-pastix-5.2-backport.patch
- "${FILESDIR}"/${PN}-3.2.7-adaolc-backport.patch
-)
-
-src_unpack() {
- default
- mv ${PN}* ${P} || die
-}
-
-src_prepare() {
- sed \
- -e 's:-g2::g' \
- -i cmake/EigenConfigureTesting.cmake || die
-
- sed -i CMakeLists.txt \
- -e "/add_subdirectory(demos/d" \
- || die "sed disable unused bundles failed"
-
- if ! use test; then
- sed -i CMakeLists.txt \
- -e "/add_subdirectory(blas/d" \
- -e "/add_subdirectory(lapack/d" \
- || die "sed disable unused bundles failed"
- fi
-
- sed -i -e "/Unknown build type/d" CMakeLists.txt || die
-
- cmake-utils_src_prepare
-}
-
-src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doc
-}
-
-src_test() {
- local mycmakeargs=(
- -DEIGEN_BUILD_TESTS=ON
- -DEIGEN_TEST_NOQT=ON
- -DEIGEN_TEST_ALTIVEC="$(usex altivec)"
- -DEIGEN_TEST_OPENMP="$(usex openmp)"
- -DEIGEN_TEST_SSE2="$(usex cpu_flags_x86_sse2)"
- -DEIGEN_TEST_SSE3="$(usex cpu_flags_x86_sse3)"
- -DEIGEN_TEST_SSE4_1="$(usex cpu_flags_x86_sse4_1)"
- -DEIGEN_TEST_SSE4_2="$(usex cpu_flags_x86_sse4_2)"
- -DEIGEN_TEST_SSSE3="$(usex cpu_flags_x86_ssse3)"
-# -DEIGEN_TEST_X87="$(usex cpu_flags_x86_x87)"
- )
- cmake-utils_src_configure
- cmake-utils_src_compile blas
- cmake-utils_src_compile buildtests
- cmake-utils_src_test
-}
-
-src_install() {
- cmake-utils_src_install
- use doc && dodoc -r "${BUILD_DIR}"/doc/html
-
- # Debian installs it and some projects started using it.
- insinto /usr/share/cmake/Modules/
- doins "${S}/cmake/FindEigen3.cmake"
-}
diff --git a/dev-cpp/eigen/eigen-3.3.5-r1.ebuild b/dev-cpp/eigen/eigen-3.3.5-r1.ebuild
deleted file mode 100644
index 2e8c6f919e8d..000000000000
--- a/dev-cpp/eigen/eigen-3.3.5-r1.ebuild
+++ /dev/null
@@ -1,101 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-FORTRAN_NEEDED="test"
-inherit cmake-utils cuda fortran-2
-
-DESCRIPTION="C++ template library for linear algebra"
-HOMEPAGE="http://eigen.tuxfamily.org/"
-SRC_URI="https://bitbucket.org/eigen/eigen/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
-
-LICENSE="MPL-2.0"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="altivec c++11 cuda debug doc neon openmp test" #zvector vsx
-RESTRICT="!test? ( test )"
-
-RDEPEND="!dev-cpp/eigen:0"
-DEPEND="
- doc? ( app-doc/doxygen[dot,latex] )
- test? (
- dev-libs/gmp:0
- dev-libs/mpfr:0
- media-libs/freeglut
- media-libs/glew
- sci-libs/adolc[sparse]
- sci-libs/cholmod
- sci-libs/fftw:3.0
- sci-libs/pastix
- sci-libs/umfpack
- sci-libs/scotch
- sci-libs/spqr
- sci-libs/superlu
- virtual/opengl
- virtual/pkgconfig
- cuda? ( dev-util/nvidia-cuda-toolkit )
- )
-"
-# Missing:
-# METIS-5
-# GOOGLEHASH
-
-PATCHES=( "${FILESDIR}/${P}-fix-prototype.patch" )
-
-src_unpack() {
- default
- mv ${PN}* ${P} || die
-}
-
-src_prepare() {
- cmake-utils_src_prepare
-
- sed -e 's:-g2::g' \
- -i cmake/EigenConfigureTesting.cmake || die
-
- sed -e "/add_subdirectory(demos/d" \
- -i CMakeLists.txt || die
-
- if ! use test; then
- sed -e "/add_subdirectory(test/d" \
- -i CMakeLists.txt || die
-
- sed -e "/add_subdirectory(blas/d" \
- -e "/add_subdirectory(lapack/d" \
- -i CMakeLists.txt || die
- fi
- sed -e "/Unknown build type/d" \
- -i CMakeLists.txt || die
-
- use cuda && cuda_src_prepare
-}
-
-src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doc
-}
-
-src_test() {
- local mycmakeargs=(
- -DEIGEN_TEST_NOQT=ON
- -DEIGEN_TEST_ALTIVEC="$(usex altivec)"
- -DEIGEN_TEST_CXX11="$(usex c++11)"
- -DEIGEN_TEST_CUDA="$(usex cuda)"
- -DEIGEN_TEST_OPENMP="$(usex openmp)"
- -DEIGEN_TEST_NEON64="$(usex neon)"
- )
- cmake-utils_src_configure
- cmake-utils_src_compile blas
- cmake-utils_src_compile buildtests
- cmake-utils_src_test
-}
-
-src_install() {
- use doc && local HTML_DOCS=( "${BUILD_DIR}"/doc/html/. )
- cmake-utils_src_install
-
- # Debian installs it and some projects started using it.
- insinto /usr/share/cmake/Modules/
- doins "${S}/cmake/FindEigen3.cmake"
-}
diff --git a/dev-cpp/eigen/files/eigen-3.2.7-adaolc-backport.patch b/dev-cpp/eigen/files/eigen-3.2.7-adaolc-backport.patch
deleted file mode 100644
index 82547e11951a..000000000000
--- a/dev-cpp/eigen/files/eigen-3.2.7-adaolc-backport.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-# HG changeset patch
-# User Gael Guennebaud <g.gael@free.fr>
-# Date 1448895622 -3600
-# Node ID e515e2706d00294a5749db7832d10ea366b9389f
-# Parent eb4bf011a2ea5fc4ddb0aa5332d6e616198ed886
-Update ADOL-C support.
-
-diff --git a/unsupported/Eigen/AdolcForward b/unsupported/Eigen/AdolcForward
---- a/unsupported/Eigen/AdolcForward
-+++ b/unsupported/Eigen/AdolcForward
-@@ -25,7 +25,7 @@
- #ifndef NUMBER_DIRECTIONS
- # define NUMBER_DIRECTIONS 2
- #endif
--#include <adolc/adouble.h>
-+#include <adolc/adtl.h>
-
- // adolc defines some very stupid macros:
- #if defined(malloc)
-diff --git a/unsupported/test/forward_adolc.cpp b/unsupported/test/forward_adolc.cpp
---- a/unsupported/test/forward_adolc.cpp
-+++ b/unsupported/test/forward_adolc.cpp
-@@ -13,8 +13,6 @@
- #define NUMBER_DIRECTIONS 16
- #include <unsupported/Eigen/AdolcForward>
-
--int adtl::ADOLC_numDir;
--
- template<typename Vector>
- EIGEN_DONT_INLINE typename Vector::Scalar foo(const Vector& p)
- {
-@@ -123,7 +121,7 @@
-
- void test_forward_adolc()
- {
-- adtl::ADOLC_numDir = NUMBER_DIRECTIONS;
-+ adtl::setNumDir(NUMBER_DIRECTIONS);
-
- for(int i = 0; i < g_repeat; i++) {
- CALL_SUBTEST(( adolc_forward_jacobian(TestFunc1<double,2,2>()) ));
diff --git a/dev-cpp/eigen/files/eigen-3.2.7-pastix-5.2-backport.patch b/dev-cpp/eigen/files/eigen-3.2.7-pastix-5.2-backport.patch
deleted file mode 100644
index fafaf3a68629..000000000000
--- a/dev-cpp/eigen/files/eigen-3.2.7-pastix-5.2-backport.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-# HG changeset patch
-# User Gael Guennebaud <g.gael@free.fr>
-# Date 1393589499 -3600
-# Node ID b88efb384b160880131ad17e39bb690719112bfa
-# Parent 576120ad694efe29b70999576964d3816288fb4e
-Fix PaStiX support for Pastix 5.2
-
-diff --git a/Eigen/src/PaStiXSupport/PaStiXSupport.h b/Eigen/src/PaStiXSupport/PaStiXSupport.h
---- a/Eigen/src/PaStiXSupport/PaStiXSupport.h
-+++ b/Eigen/src/PaStiXSupport/PaStiXSupport.h
-@@ -12,6 +12,14 @@
-
- namespace Eigen {
-
-+#if defined(DCOMPLEX)
-+ #define PASTIX_COMPLEX COMPLEX
-+ #define PASTIX_DCOMPLEX DCOMPLEX
-+#else
-+ #define PASTIX_COMPLEX std::complex<float>
-+ #define PASTIX_DCOMPLEX std::complex<double>
-+#endif
-+
- /** \ingroup PaStiXSupport_Module
- * \brief Interface to the PaStix solver
- *
-@@ -74,14 +82,14 @@
- {
- if (n == 0) { ptr = NULL; idx = NULL; vals = NULL; }
- if (nbrhs == 0) {x = NULL; nbrhs=1;}
-- c_pastix(pastix_data, pastix_comm, n, ptr, idx, reinterpret_cast<COMPLEX*>(vals), perm, invp, reinterpret_cast<COMPLEX*>(x), nbrhs, iparm, dparm);
-+ c_pastix(pastix_data, pastix_comm, n, ptr, idx, reinterpret_cast<PASTIX_COMPLEX*>(vals), perm, invp, reinterpret_cast<PASTIX_COMPLEX*>(x), nbrhs, iparm, dparm);
- }
-
- void eigen_pastix(pastix_data_t **pastix_data, int pastix_comm, int n, int *ptr, int *idx, std::complex<double> *vals, int *perm, int * invp, std::complex<double> *x, int nbrhs, int *iparm, double *dparm)
- {
- if (n == 0) { ptr = NULL; idx = NULL; vals = NULL; }
- if (nbrhs == 0) {x = NULL; nbrhs=1;}
-- z_pastix(pastix_data, pastix_comm, n, ptr, idx, reinterpret_cast<DCOMPLEX*>(vals), perm, invp, reinterpret_cast<DCOMPLEX*>(x), nbrhs, iparm, dparm);
-+ z_pastix(pastix_data, pastix_comm, n, ptr, idx, reinterpret_cast<PASTIX_DCOMPLEX*>(vals), perm, invp, reinterpret_cast<PASTIX_DCOMPLEX*>(x), nbrhs, iparm, dparm);
- }
-
- // Convert the matrix to Fortran-style Numbering
diff --git a/dev-cpp/eigen/files/eigen-3.3.5-fix-prototype.patch b/dev-cpp/eigen/files/eigen-3.3.5-fix-prototype.patch
deleted file mode 100644
index e4d128f502e3..000000000000
--- a/dev-cpp/eigen/files/eigen-3.3.5-fix-prototype.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-# HG changeset patch
-# User Gael Guennebaud <g.gael@free.fr>
-# Date 1528444561 -7200
-# Node ID 27cac8430247a65739fcd0b83ef984d0a9c010c7
-# Parent d4cbff8d06baf95045869ed7d0c012d641c88fcf
-fix prototype
-
-diff --git a/unsupported/Eigen/src/IterativeSolvers/DGMRES.h b/unsupported/Eigen/src/IterativeSolvers/DGMRES.h
---- a/unsupported/Eigen/src/IterativeSolvers/DGMRES.h
-+++ b/unsupported/Eigen/src/IterativeSolvers/DGMRES.h
-@@ -173,7 +173,7 @@
- /**
- * Set the restart value (default is 30)
- */
-- Index set_restart(const Index restart) { m_restart=restart; }
-+ void set_restart(const Index restart) { m_restart=restart; }
-
- /**
- * Set the number of eigenvalues to deflate at each restart \ No newline at end of file