summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/gflags/files/gflags-2.1.1-libs.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/gflags/files/gflags-2.1.1-libs.patch')
-rw-r--r--dev-cpp/gflags/files/gflags-2.1.1-libs.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-cpp/gflags/files/gflags-2.1.1-libs.patch b/dev-cpp/gflags/files/gflags-2.1.1-libs.patch
new file mode 100644
index 000000000000..0e59cb937e14
--- /dev/null
+++ b/dev-cpp/gflags/files/gflags-2.1.1-libs.patch
@@ -0,0 +1,45 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 17d38b4..ca2c1df 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -22,6 +22,8 @@ version_numbers (
+ PACKAGE_VERSION_PATCH
+ )
+
++set (PACKAGE_SOVERSION "${PACKAGE_VERSION_MAJOR}")
++
+ # ----------------------------------------------------------------------------
+ # options
+ set (GFLAGS_NAMESPACE "${PACKAGE_NAME}" CACHE STRING "C++ namespace identifier of gflags library.")
+@@ -256,7 +258,9 @@ foreach (TYPE IN ITEMS STATIC SHARED)
+ endif ()
+ set_target_properties (
+ gflags${opts}-${type} PROPERTIES COMPILE_DEFINITIONS "${defines}"
+- OUTPUT_NAME "gflags${opts}"
++ OUTPUT_NAME "gflags${opts}"
++ VERSION "${PACKAGE_VERSION}"
++ SOVERSION "${PACKAGE_SOVERSION}"
+ )
+ if (HAVE_SHLWAPI_H)
+ target_link_libraries (gflags${opts}-${type} shlwapi.lib)
+@@ -280,9 +284,18 @@ if (OS_WINDOWS)
+ set (CONFIG_INSTALL_DIR CMake)
+ else ()
+ set (RUNTIME_INSTALL_DIR bin)
+- set (LIBRARY_INSTALL_DIR lib)
++ # The LIB_INSTALL_DIR and LIB_SUFFIX variables are used by the Fedora
++ # package maintainers. Also package maintainers of other distribution
++ # packages need to be able to specify the name of the library directory.
++ if (NOT LIB_INSTALL_DIR)
++ set (LIB_INSTALL_DIR "lib${LIB_SUFFIX}")
++ endif ()
++ set (LIBRARY_INSTALL_DIR "${LIB_INSTALL_DIR}"
++ CACHE PATH "Directory of installed libraries, e.g., \"lib64\""
++ )
++ mark_as_advanced (LIBRARY_INSTALL_DIR)
+ set (INCLUDE_INSTALL_DIR include)
+- set (CONFIG_INSTALL_DIR lib/cmake/${PACKAGE_NAME})
++ set (CONFIG_INSTALL_DIR ${LIBRARY_INSTALL_DIR}/cmake/${PACKAGE_NAME})
+ endif ()
+
+ file (RELATIVE_PATH INSTALL_PREFIX_REL2CONFIG_DIR "${CMAKE_INSTALL_PREFIX}/${CONFIG_INSTALL_DIR}" "${CMAKE_INSTALL_PREFIX}")