summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-18 21:11:03 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-18 21:26:22 +0200
commiteec92eb44c6b9cb11d81b1f7d6a7cbbe8aa38e30 (patch)
tree42475ba6ffa9d8ba613bc334738c876f8d18bb2b /dev-cpp/gtest/gtest-1.6.0.ebuild
parentdev-cpp/ctemplate: Drop old (diff)
downloadgentoo-eec92eb44c6b9cb11d81b1f7d6a7cbbe8aa38e30.tar.gz
gentoo-eec92eb44c6b9cb11d81b1f7d6a7cbbe8aa38e30.tar.bz2
gentoo-eec92eb44c6b9cb11d81b1f7d6a7cbbe8aa38e30.zip
dev-cpp/gtest: Drop old
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-cpp/gtest/gtest-1.6.0.ebuild')
-rw-r--r--dev-cpp/gtest/gtest-1.6.0.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-cpp/gtest/gtest-1.6.0.ebuild b/dev-cpp/gtest/gtest-1.6.0.ebuild
deleted file mode 100644
index 4aa69f8c1f81..000000000000
--- a/dev-cpp/gtest/gtest-1.6.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-PYTHON_DEPEND="2"
-
-inherit python libtool
-
-DESCRIPTION="Google C++ Testing Framework"
-HOMEPAGE="https://github.com/google/googletest"
-SRC_URI="https://googletest.googlecode.com/files/${P}.zip"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos"
-IUSE="examples threads static-libs"
-
-DEPEND="app-arch/unzip"
-RDEPEND=""
-
-pkg_setup() {
- python_pkg_setup
- python_set_active_version 2
-}
-
-src_prepare() {
- sed -i -e "s|/tmp|${T}|g" test/gtest-filepath_test.cc || die
- sed -i -r \
- -e '/^install-(data|exec)-local:/s|^.*$|&\ndisabled-&|' \
- Makefile.in
- elibtoolize
-
- python_convert_shebangs -r 2 .
-}
-
-src_configure() {
- econf \
- $(use_enable static-libs static) \
- $(use_with threads pthreads)
-}
-
-src_test() {
- # explicitly use parallel make
- emake check || die
-}
-
-src_install() {
- default
- dobin scripts/gtest-config
-
- if ! use static-libs ; then
- rm "${ED}"/usr/lib*/*.la || die
- fi
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples
- doins samples/*.{cc,h}
- fi
-}