summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-01-16 11:55:57 +0100
committerPacho Ramos <pacho@gentoo.org>2016-01-16 11:56:42 +0100
commit9c9c81dec0e264f29d52d9b9c14df9fc6fe5e63f (patch)
treed8b982d21aa82ff47b5cf9d3869d635e355b4691 /dev-cpp/gtkmm
parentdev-cpp/gtkmm: Drop old (diff)
downloadgentoo-9c9c81dec0e264f29d52d9b9c14df9fc6fe5e63f.tar.gz
gentoo-9c9c81dec0e264f29d52d9b9c14df9fc6fe5e63f.tar.bz2
gentoo-9c9c81dec0e264f29d52d9b9c14df9fc6fe5e63f.zip
dev-cpp/gtkmm: Fix compilation with gcc-4.7 (#567882 by Émeric Maschino)
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-cpp/gtkmm')
-rw-r--r--dev-cpp/gtkmm/files/gtkmm-3.18.0-gcc47.patch44
-rw-r--r--dev-cpp/gtkmm/gtkmm-3.18.0-r1.ebuild5
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-cpp/gtkmm/files/gtkmm-3.18.0-gcc47.patch b/dev-cpp/gtkmm/files/gtkmm-3.18.0-gcc47.patch
new file mode 100644
index 000000000000..6a70cd6b1636
--- /dev/null
+++ b/dev-cpp/gtkmm/files/gtkmm-3.18.0-gcc47.patch
@@ -0,0 +1,44 @@
+--- a/gtk/src/menushell.ccg 2015-07-16 21:00:55.000000000 +0200
++++ b/gtk/src/menushell.ccg 2015-12-09 01:03:45.127863899 +0100
+@@ -43,7 +43,7 @@ MenuShell::MenuShell(GtkMenuShell* casti
+ {}
+
+ // TODO: Why do we need a custom dtor?
+-MenuShell::~MenuShell()
++MenuShell::~MenuShell() noexcept
+ {}
+
+ void MenuShell::accelerate(Window& window)
+--- a/gtk/gtkmm/menushell.cc 2015-09-22 11:41:47.000000000 +0200
++++ b/gtk/gtkmm/menushell.cc 2015-12-09 01:06:27.641701385 +0100
+@@ -54,7 +54,7 @@ MenuShell::MenuShell(GtkMenuShell* casti
+ {}
+
+ // TODO: Why do we need a custom dtor?
+-MenuShell::~MenuShell()
++MenuShell::~MenuShell() noexcept
+ {}
+
+ void MenuShell::accelerate(Window& window)
+--- a/gtk/src/widget.ccg 2015-07-16 21:00:55.000000000 +0200
++++ b/gtk/src/widget.ccg 2015-12-09 07:36:47.328538621 +0100
+@@ -413,7 +413,7 @@ void Widget_Class::get_preferred_width_f
+ (*base->get_preferred_width_for_height)(self, height, minimum_width, natural_width);
+ }
+
+-Widget::~Widget()
++Widget::~Widget() noexcept
+ {}
+
+ void Widget::reparent(Widget& new_parent)
+--- a/gtk/gtkmm/widget.cc 2015-09-22 11:44:13.000000000 +0200
++++ b/gtk/gtkmm/widget.cc 2015-12-09 07:39:29.318214641 +0100
+@@ -423,7 +423,7 @@ void Widget_Class::get_preferred_width_f
+ (*base->get_preferred_width_for_height)(self, height, minimum_width, natural_width);
+ }
+
+-Widget::~Widget()
++Widget::~Widget() noexcept
+ {}
+
+ void Widget::reparent(Widget& new_parent)
diff --git a/dev-cpp/gtkmm/gtkmm-3.18.0-r1.ebuild b/dev-cpp/gtkmm/gtkmm-3.18.0-r1.ebuild
index 14aad8734783..401ce9966c41 100644
--- a/dev-cpp/gtkmm/gtkmm-3.18.0-r1.ebuild
+++ b/dev-cpp/gtkmm/gtkmm-3.18.0-r1.ebuild
@@ -5,7 +5,7 @@
EAPI="5"
GCONF_DEBUG="no"
-inherit gnome2 multilib-minimal
+inherit eutils gnome2 multilib-minimal
DESCRIPTION="C++ interface for GTK+"
HOMEPAGE="http://www.gtkmm.org"
@@ -37,6 +37,9 @@ DEPEND="${RDEPEND}
# eautoreconf needs mm-common
src_prepare() {
+ # Fix building with gcc-4.7, fixed in next version, bug #567882
+ epatch "${FILESDIR}"/${P}-gcc47.patch
+
if ! use test; then
# don't waste time building tests
sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \