summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-cpp/libfrontend-elements
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-cpp/libfrontend-elements')
-rw-r--r--dev-cpp/libfrontend-elements/Manifest1
-rw-r--r--dev-cpp/libfrontend-elements/libfrontend-elements-1.1.4.ebuild82
-rw-r--r--dev-cpp/libfrontend-elements/metadata.xml8
3 files changed, 91 insertions, 0 deletions
diff --git a/dev-cpp/libfrontend-elements/Manifest b/dev-cpp/libfrontend-elements/Manifest
new file mode 100644
index 000000000000..3f215748ff37
--- /dev/null
+++ b/dev-cpp/libfrontend-elements/Manifest
@@ -0,0 +1 @@
+DIST libfrontend-elements-1.1.4.tar.bz2 17766 SHA256 ea1cdf861e5922af9a1b85371fe76d0bcbbc17ca0939e907a8fde552f5900b63 SHA512 2d371259171fdc5605b9ada6e4036fb8ac6ea09e6dbaf13d90651cf532b2ffa2f007ccf8e4b42bf1e333df1bc31a7434f7b68a6a15e2090eea462a97b4188afe WHIRLPOOL 65a60689c401efda4fa1813af3f97245c80ec4fa285d52b593a3e9dcbb3402b1768e0378f45d54abbef4bd32f59535c589b4a092fd3bedb240a06e991d17671a
diff --git a/dev-cpp/libfrontend-elements/libfrontend-elements-1.1.4.ebuild b/dev-cpp/libfrontend-elements/libfrontend-elements-1.1.4.ebuild
new file mode 100644
index 000000000000..c0a6b03f4c0b
--- /dev/null
+++ b/dev-cpp/libfrontend-elements/libfrontend-elements-1.1.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs versionator
+
+DESCRIPTION="A collection of elementary building blocks for implementing compiler frontends in c++"
+HOMEPAGE="http://kolpackov.net/projects/libfrontend-elements/"
+SRC_URI="ftp://kolpackov.net/pub/projects/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ppc ppc64 x86"
+IUSE="examples"
+
+RDEPEND=">=dev-cpp/libcult-1.4.6-r1"
+DEPEND="${RDEPEND}
+ dev-util/build:0.3"
+
+src_prepare() {
+ # never build the examples
+ sed -i \
+ -e 's| $(out_base)/examples/[[:alnum:]\.]*||' \
+ -e '/examples\/makefile/d' \
+ makefile || die "sed failed"
+}
+
+src_configure() {
+ mkdir -p build/{ld,cxx/gnu,import/libcult}
+
+ cat >> build/cxx/configuration-dynamic.make <<- EOF
+cxx_id := gnu
+cxx_optimize := n
+cxx_debug := n
+cxx_rpath := n
+cxx_pp_extra_options :=
+cxx_extra_options := ${CXXFLAGS}
+cxx_ld_extra_options := ${LDFLAGS}
+cxx_extra_libs :=
+cxx_extra_lib_paths :=
+ EOF
+
+ cat >> build/cxx/gnu/configuration-dynamic.make <<- EOF
+cxx_gnu := $(tc-getCXX)
+cxx_gnu_libraries :=
+cxx_gnu_optimization_options :=
+ EOF
+
+ cat >> build/import/libcult/configuration-dynamic.make <<- EOF
+libcult_installed := y
+ EOF
+
+ cat >> build/ld/configuration-lib-dynamic.make <<- EOF
+ld_lib_type := shared
+ EOF
+
+ MAKEOPTS+=" verbose=1"
+}
+
+src_install() {
+ dolib.so frontend-elements/libfrontend-elements.so
+
+ find frontend-elements -iname "*.cxx" \
+ -o -iname "makefile" \
+ -o -iname "*.o" -o -iname "*.d" \
+ -o -iname "*.m4" -o -iname "*.l" \
+ -o -iname "*.cpp-options" -o -iname "*.so" | xargs rm -f
+ rm -rf frontend-elements/arch
+
+ insinto /usr/include
+ doins -r frontend-elements
+
+ dodoc NEWS README documentation/[[:upper:]]*
+ dohtml -A xhtml -r documentation/*
+
+ if use examples ; then
+ find examples -name makefile -delete
+ # preserving symlinks in the examples
+ cp -dpR examples "${D}/usr/share/doc/${PF}"
+ fi
+}
diff --git a/dev-cpp/libfrontend-elements/metadata.xml b/dev-cpp/libfrontend-elements/metadata.xml
new file mode 100644
index 000000000000..75dd2ca7d302
--- /dev/null
+++ b/dev-cpp/libfrontend-elements/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>dev-zero@gentoo.org</email>
+ <name>Tiziano Müller</name>
+ </maintainer>
+</pkgmetadata>