summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-10-14 15:48:27 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-10-22 18:13:49 +0200
commit1593c2fdcaeb97085146a8f345b7ce2458a928fb (patch)
tree3ae32b82f4a510f49819248138c56f7d0a5493e4 /dev-cpp/lucene++
parentnet-analyzer/icinga2: 2.10.1-r1 stable amd64 and x86 (diff)
downloadgentoo-1593c2fdcaeb97085146a8f345b7ce2458a928fb.tar.gz
gentoo-1593c2fdcaeb97085146a8f345b7ce2458a928fb.tar.bz2
gentoo-1593c2fdcaeb97085146a8f345b7ce2458a928fb.zip
dev-cpp/lucene++: EAPI-6 bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10144
Diffstat (limited to 'dev-cpp/lucene++')
-rw-r--r--dev-cpp/lucene++/lucene++-3.0.7-r1.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-cpp/lucene++/lucene++-3.0.7-r1.ebuild b/dev-cpp/lucene++/lucene++-3.0.7-r1.ebuild
new file mode 100644
index 000000000000..731f88718271
--- /dev/null
+++ b/dev-cpp/lucene++/lucene++-3.0.7-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="LucenePlusPlus-rel_${PV}"
+inherit cmake-utils
+
+DESCRIPTION="C++ port of Lucene library, a high-performance, full-featured text search engine"
+HOMEPAGE="https://github.com/luceneplusplus/LucenePlusPlus"
+SRC_URI="https://github.com/luceneplusplus/LucenePlusPlus/archive/rel_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="|| ( LGPL-3 Apache-2.0 )"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc ppc64 sparc x86"
+IUSE="debug"
+
+DEPEND="dev-libs/boost:="
+RDEPEND="${DEPEND}"
+
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS README.rst )
+
+PATCHES=( "${FILESDIR}/${P}-boost-1.58.patch" )
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEMO=OFF
+ -DENABLE_TEST=OFF
+ )
+
+ cmake-utils_src_configure
+}