summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-23 15:04:23 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-23 15:04:30 +0200
commit96ff8d893a1f0ff086c9c55d36f84e22a3e22993 (patch)
tree5e5d7aa30b9dd5e811265caef7d880b15202f79e /dev-cpp/tbb
parentdev-python/pyfltk: Drop old (diff)
downloadgentoo-96ff8d893a1f0ff086c9c55d36f84e22a3e22993.tar.gz
gentoo-96ff8d893a1f0ff086c9c55d36f84e22a3e22993.tar.bz2
gentoo-96ff8d893a1f0ff086c9c55d36f84e22a3e22993.zip
dev-cpp/tbb: Drop old
Package-Manager: portage-2.2.21 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-cpp/tbb')
-rw-r--r--dev-cpp/tbb/Manifest1
-rw-r--r--dev-cpp/tbb/tbb-4.3.20141023.ebuild127
2 files changed, 0 insertions, 128 deletions
diff --git a/dev-cpp/tbb/Manifest b/dev-cpp/tbb/Manifest
index b19a8e57f213..2f8b59e896f4 100644
--- a/dev-cpp/tbb/Manifest
+++ b/dev-cpp/tbb/Manifest
@@ -1,2 +1 @@
-DIST tbb43_20141023oss_src.tgz 2777177 SHA256 247a8d22d6850caa37d376aaeaf8bfcb06525ec5561fb6f6ed09cdad2c1f6414 SHA512 0718e7bf5f0b9525da9eb45beedc1c3832ccd813d72b10a7ed7c6a281d342325d04c65f797c29e2551d4f2bd470e57c81f38db0d6bd983f7871a90f2b5fe5020 WHIRLPOOL 7a6bc75e9404cbfc9f1e1bc53ff195e63c605aae1cc2883147d69bdd394694d21f916fa6d1c2708ff397a01c620fdb38966d0da5085df6d23dcba235de18c6a8
DIST tbb43_20150611oss_src.tgz 2757631 SHA256 221f85fe64e11c9638e43b3c57d5750c26683905fc90827c0bcfefdb286e79c9 SHA512 83d5d827706b774ef5cd6df8082e5d7f48683388684423bb40565dfc25892fc2e57c382f719b78087d83e51edb3f7f7215f33d8b5039b55c32788d80efa6e0b8 WHIRLPOOL 8e98162b2307c759fb26923d76ab784dea81e166c8bf5323869d234da59641c333e5ae30b4a224bccbf20d4f5f6b75c658589f519a165ea3ad7658322f148c72
diff --git a/dev-cpp/tbb/tbb-4.3.20141023.ebuild b/dev-cpp/tbb/tbb-4.3.20141023.ebuild
deleted file mode 100644
index 5edd36915ed1..000000000000
--- a/dev-cpp/tbb/tbb-4.3.20141023.ebuild
+++ /dev/null
@@ -1,127 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit eutils flag-o-matic multilib versionator toolchain-funcs
-
-PV1="$(get_version_component_range 1)"
-PV2="$(get_version_component_range 2)"
-PV3="$(get_version_component_range 3)"
-MYP="${PN}${PV1}${PV2}_${PV3}oss"
-
-DESCRIPTION="High level abstract threading library"
-HOMEPAGE="http://www.threadingbuildingblocks.org/"
-SRC_URI="http://threadingbuildingblocks.org/sites/default/files/software_releases/source/${MYP}_src.tgz"
-LICENSE="GPL-2-with-exceptions"
-
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
-IUSE="debug doc examples"
-
-DEPEND=""
-RDEPEND="${DEPEND}"
-S="${WORKDIR}/${MYP}"
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-4.0.297-underlinking.patch
- # use fully qualified gcc compilers. do not force march/mcpu
- # not tested with icc
- # order in sed expressions is important
- sed -i \
- -e "s/g++/$(tc-getCXX)/g" \
- -e "s/gcc/$(tc-getCC)/g" \
- -e 's/-m\(arch\|cpu\)=*[[:space:]]//g' \
- -e 's/-\(m\|-\)\(64\|32\)//g' \
- -e 's/-O2/$(CXXFLAGS)/g' \
- -e "/^ASM/s/as/$(tc-getAS)/g" \
- build/*.gcc.inc || die
-
- # Give it a soname on FreeBSD
- echo 'LIB_LINK_FLAGS += -Wl,-soname=$(BUILDING_LIBRARY)' >> build/FreeBSD.gcc.inc
- # Set proper versionning on FreeBSD
- sed -i -e '/.DLL =/s/$/.1/' build/FreeBSD.inc || die
-
- # force 64bit where applicable, 32bit where applicable...
- # built-in detection is based on running kernel, which messes up
- # e.g. in a x86 chroot on amd64 kernel. Bug 462130
- # see build/linux.inc for values
- use amd64 && export arch=x86_64
- use amd64-linux && export arch=x86_64
- use x86 && export arch=ia32
- use x86-linux && export arch=ia32
- # no idea what to do with ppc but so far it seems to work
-
- find include -name \*.html -delete || die
-
- # pc files are for debian and fedora compatibility
- # some deps use them
- cat <<-EOF > ${PN}.pc.template
- prefix=${EPREFIX}/usr
- libdir=\${prefix}/$(get_libdir)
- includedir=\${prefix}/include
- Name: ${PN}
- Description: ${DESCRIPTION}
- Version: ${PV}
- URL: ${HOMEPAGE}
- Cflags: -I\${includedir}
- EOF
- cp ${PN}.pc.template ${PN}.pc
- cat <<-EOF >> ${PN}.pc
- Libs: -L\${libdir} -ltbb
- Libs.private: -lm -lrt
- EOF
- cp ${PN}.pc.template ${PN}malloc.pc
- cat <<-EOF >> ${PN}malloc.pc
- Libs: -L\${libdir} -ltbbmalloc
- Libs.private: -lm -lrt
- EOF
- cp ${PN}.pc.template ${PN}malloc_proxy.pc
- cat <<-EOF >> ${PN}malloc_proxy.pc
- Libs: -L\${libdir} -ltbbmalloc_proxy
- Libs.private: -lrt
- Requires: tbbmalloc
- EOF
- use debug || sed -i -e '/_debug/d' Makefile
-}
-
-src_compile() {
- if [[ $(tc-getCXX) == *g++* ]]; then
- comp="gcc"
- elif [[ $(tc-getCXX) == *ic*c ]]; then
- comp="icc"
- else
- die "compiler $(tc-getCXX) not supported by build system"
- fi
- emake compiler=${comp} tbb tbbmalloc
-}
-
-src_test() {
- append-cxxflags -fabi-version=4
- # avoid oversubscribing with -j1
- emake -j1 compiler=${comp} test
-}
-
-src_install(){
- local l
- for l in $(find build -name lib\*.so.\*); do
- dolib.so ${l}
- local bl=$(basename ${l})
- dosym ${bl} /usr/$(get_libdir)/${bl%.*}
- done
- doheader -r include/*
-
- insinto /usr/$(get_libdir)/pkgconfig
- doins *.pc
-
- dodoc README CHANGES doc/Release_Notes.txt
- use doc && dohtml -r doc/html/*
-
- if use examples ; then
- insinto /usr/share/doc/${PF}/examples/build
- doins build/*.inc
- insinto /usr/share/doc/${PF}/examples
- doins -r examples
- fi
-}