summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Breathitt Gray <vilhelm.gray@gmail.com>2021-01-10 06:37:54 +0900
committerSergei Trofimovich <slyfox@gentoo.org>2021-01-11 17:45:25 +0000
commit4add4f893cf2fb16b18d3c15bc9948a80802b66f (patch)
treea81c6a2f67107b97e01de6b8222d9128e3afa1c2 /dev-cpp
parentdev-python/pyopenssl: stable 20.0.0-r1 for hppa, bug #763768 (diff)
downloadgentoo-4add4f893cf2fb16b18d3c15bc9948a80802b66f.tar.gz
gentoo-4add4f893cf2fb16b18d3c15bc9948a80802b66f.tar.bz2
gentoo-4add4f893cf2fb16b18d3c15bc9948a80802b66f.zip
dev-cpp/benchmark: Add patch to fix build failure on gcc-11
Closes: https://bugs.gentoo.org/764647 Signed-off-by: William Breathitt Gray <vilhelm.gray@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/19012 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/benchmark/benchmark-1.5.2.ebuild4
-rw-r--r--dev-cpp/benchmark/files/benchmark-1.5.2-Add-missing-limits-inclusion.patch30
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/benchmark/benchmark-1.5.2.ebuild b/dev-cpp/benchmark/benchmark-1.5.2.ebuild
index 396642b38c38..e3a3e8cfb6eb 100644
--- a/dev-cpp/benchmark/benchmark-1.5.2.ebuild
+++ b/dev-cpp/benchmark/benchmark-1.5.2.ebuild
@@ -15,6 +15,10 @@ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
IUSE="test"
RESTRICT="!test? ( test )"
+PATCHES=(
+ "${FILESDIR}/${P}-Add-missing-limits-inclusion.patch"
+)
+
src_configure() {
local mycmakeargs=(
-DBENCHMARK_ENABLE_TESTING=$(usex test)
diff --git a/dev-cpp/benchmark/files/benchmark-1.5.2-Add-missing-limits-inclusion.patch b/dev-cpp/benchmark/files/benchmark-1.5.2-Add-missing-limits-inclusion.patch
new file mode 100644
index 000000000000..42bdbbef1f43
--- /dev/null
+++ b/dev-cpp/benchmark/files/benchmark-1.5.2-Add-missing-limits-inclusion.patch
@@ -0,0 +1,30 @@
+From 3d1c2677686718d906f28c1d4da001c42666e6d2 Mon Sep 17 00:00:00 2001
+From: Sergei Trofimovich <slyfox@inbox.ru>
+Date: Thu, 15 Oct 2020 09:12:40 +0100
+Subject: [PATCH] src/benchmark_register.h: add missing <limits> inclusion
+ (#1060)
+
+Noticed missing header when was building llvm with gcc-11:
+
+```
+llvm-project/llvm/utils/benchmark/src/benchmark_register.h:17:30:
+ error: 'numeric_limits' is not a member of 'std'
+ 17 | static const T kmax = std::numeric_limits<T>::max();
+ | ^~~~~~~~~~~~~~
+```
+---
+ src/benchmark_register.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/benchmark_register.h b/src/benchmark_register.h
+index 61377d74..204bf1d9 100644
+--- a/src/benchmark_register.h
++++ b/src/benchmark_register.h
+@@ -1,6 +1,7 @@
+ #ifndef BENCHMARK_REGISTER_H
+ #define BENCHMARK_REGISTER_H
+
++#include <limits>
+ #include <vector>
+
+ #include "check.h"