summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2015-12-23 11:30:29 +0100
committerPacho Ramos <pacho@gentoo.org>2015-12-23 11:58:45 +0100
commit5be33bd03fad163b1f42fdc52f4ad8fca49fc52c (patch)
tree6022e57294f900867a55c3ac11807a813b18161e /dev-cpp
parentnet-misc/sobby: Make repoman happier about ambiguous gmp slot (diff)
downloadgentoo-5be33bd03fad163b1f42fdc52f4ad8fca49fc52c.tar.gz
gentoo-5be33bd03fad163b1f42fdc52f4ad8fca49fc52c.tar.bz2
gentoo-5be33bd03fad163b1f42fdc52f4ad8fca49fc52c.zip
dev-cpp/libgnomemm: Fix building with latest glibmm/libsigc++
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/libgnomemm/libgnomemm-2.30.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-cpp/libgnomemm/libgnomemm-2.30.0-r1.ebuild b/dev-cpp/libgnomemm/libgnomemm-2.30.0-r1.ebuild
new file mode 100644
index 000000000000..4e681b7e87d5
--- /dev/null
+++ b/dev-cpp/libgnomemm/libgnomemm-2.30.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+GNOME2_LA_PUNT="yes"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit flag-o-matic gnome2
+
+DESCRIPTION="C++ bindings for libgnome"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1"
+SLOT="2.6"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ >=dev-cpp/gtkmm-2.8:2.4
+ >=gnome-base/libgnome-2.6
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ append-cxxflags -std=c++11
+ gnome2_src_prepare
+}