summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2024-11-08 18:24:08 +0100
committerMiroslav Šulc <fordfrog@gentoo.org>2024-11-25 09:05:36 +0100
commitc97555c833c5bd2d758315d6eac13b71e0efb498 (patch)
tree915889d5d5261fa09858b5a282aba50c9d17c6ae /dev-db/apgdiff
parentdev-java/antlr: style update, update EAPI 7 -> 8 (diff)
downloadgentoo-c97555c833c5bd2d758315d6eac13b71e0efb498.tar.gz
gentoo-c97555c833c5bd2d758315d6eac13b71e0efb498.tar.bz2
gentoo-c97555c833c5bd2d758315d6eac13b71e0efb498.zip
dev-db/apgdiff: style update, update EAPI 7 -> 8
Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/39233/commits/59ed8573709cd9513beba78dc5f365dc4532c3fb Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
Diffstat (limited to 'dev-db/apgdiff')
-rw-r--r--dev-db/apgdiff/apgdiff-2.7.0-r1.ebuild (renamed from dev-db/apgdiff/apgdiff-2.7.0.ebuild)25
1 files changed, 5 insertions, 20 deletions
diff --git a/dev-db/apgdiff/apgdiff-2.7.0.ebuild b/dev-db/apgdiff/apgdiff-2.7.0-r1.ebuild
index 25a2bab6828c..8295ae9059f6 100644
--- a/dev-db/apgdiff/apgdiff-2.7.0.ebuild
+++ b/dev-db/apgdiff/apgdiff-2.7.0-r1.ebuild
@@ -1,10 +1,7 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-# Skeleton command:
-# java-ebuilder --generate-ebuild --workdir . --pom pom.xml --download-uri https://github.com/fordfrog/apgdiff/archive/refs/tags/release_2.7.0.tar.gz --slot 0 --keywords "~amd64 ~x86" --ebuild apgdiff-2.7.0.ebuild
-
-EAPI=7
+EAPI=8
JAVA_PKG_IUSE="doc source test"
MAVEN_ID="cz.startnet:apgdiff:2.7.0"
@@ -14,33 +11,21 @@ inherit java-pkg-2 java-pkg-simple
DESCRIPTION="A simple PostgreSQL diff tool that is useful for schema upgrades"
HOMEPAGE="https://github.com/fordfrog/apgdiff https://www.apgdiff.com/"
-SRC_URI="https://github.com/fordfrog/${PN}/archive/refs/tags/release_${PV}.tar.gz -> ${P}-sources.tar.gz"
+SRC_URI="https://github.com/fordfrog/${PN}/archive/release_${PV}.tar.gz -> ${P}-sources.tar.gz"
+S="${WORKDIR}/${PN}-release_${PV}"
+
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
-# Compile dependencies
-# POM: pom.xml
-# test? junit:junit:4.13.1 -> >=dev-java/junit-4.13.2:4
-# test? org.hamcrest:hamcrest-all:1.3 -> !!!artifactId-not-found!!!
-
DEPEND="
>=virtual/jdk-1.8:*
- ${CDEPEND}
test? (
dev-java/hamcrest-core:0
)
"
-RDEPEND="
- >=virtual/jre-1.8:*
- ${CDEPEND}"
-
-RESTRICT="!test? ( test )"
-
-S="${WORKDIR}/${PN}-release_${PV}"
-
-JAVA_LAUNCHER_FILENAME="${PN}"
+RDEPEND=">=virtual/jre-1.8:*"
JAVA_SRC_DIR="src/main/java"
JAVA_MAIN_CLASS="cz.startnet.utils.pgdiff.Main"