summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2019-08-17 14:56:43 +0200
committerThomas Deutschmann <whissi@gentoo.org>2019-08-17 15:45:22 +0200
commit7f9e0c126112c4245aef8ae0eeb639d58dd39660 (patch)
treeb89fb47252f918e60aee17b41a58e81654136b75 /dev-db/mysql/mysql-5.7.26.ebuild
parentdev-libs/appstream: 0.12.8 version bump (diff)
downloadgentoo-7f9e0c126112c4245aef8ae0eeb639d58dd39660.tar.gz
gentoo-7f9e0c126112c4245aef8ae0eeb639d58dd39660.tar.bz2
gentoo-7f9e0c126112c4245aef8ae0eeb639d58dd39660.zip
dev-db/mysql: update disabled tests list
Package-Manager: Portage-2.3.71, Repoman-2.3.17 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-db/mysql/mysql-5.7.26.ebuild')
-rw-r--r--dev-db/mysql/mysql-5.7.26.ebuild28
1 files changed, 21 insertions, 7 deletions
diff --git a/dev-db/mysql/mysql-5.7.26.ebuild b/dev-db/mysql/mysql-5.7.26.ebuild
index a956940eb6f7..e7e64676eaca 100644
--- a/dev-db/mysql/mysql-5.7.26.ebuild
+++ b/dev-db/mysql/mysql-5.7.26.ebuild
@@ -546,15 +546,29 @@ src_test() {
# Unstable tests
# - main.xa_prepared_binlog_off: https://bugs.mysql.com/bug.php?id=83340
+ # - rpl.rpl_innodb_info_tbl_slave_tmp_tbl_mismatch: https://bugs.mysql.com/bug.php?id=89223
# - rpl.rpl_non_direct_stm_mixing_engines: MDEV-14489
- for t in main.xa_prepared_binlog_off rpl.rpl_non_direct_stm_mixing_engines ; do
- _disable_test "$t" "Unstable test"
+ for t in \
+ main.xa_prepared_binlog_off \
+ rpl.rpl_innodb_info_tbl_slave_tmp_tbl_mismatch \
+ rpl.rpl_non_direct_stm_mixing_engines \
+ ; do
+ _disable_test "$t" "Unstable test"
done
- if ! use amd64 ; then
- # fixed in >=mysql-8 via commit 0a417e84
- _disable_test "gis.gis_bugs_crashes" "Unstable results on non-amd64 architectures due to floating-point operation"
- fi
+ for t in \
+ gis.geometry_class_attri_prop \
+ gis.geometry_property_function_issimple \
+ gis.gis_bugs_crashes \
+ gis.spatial_op_testingfunc_mix \
+ gis.spatial_analysis_functions_buffer \
+ gis.spatial_analysis_functions_distance \
+ gis.spatial_utility_function_distance_sphere \
+ gis.spatial_utility_function_simplify \
+ gis.spatial_analysis_functions_centroid \
+ ; do
+ _disable_test "$t" "Known rounding error with latest AMD processors"
+ done
if use numa && use kernel_linux ; then
# bug 584880
@@ -587,7 +601,7 @@ src_test() {
rpl.rpl_xa_survive_disconnect_lsu_off \
rpl.rpl_xa_survive_disconnect_table \
; do
- _disable_test "$t" "requires DEFAULT_CHARSET=latin1 but USE=-latin1 is set"
+ _disable_test "$t" "Requires DEFAULT_CHARSET=latin1 but USE=-latin1 is set"
done
fi