summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-10-20 10:35:27 -0400
committerBrian Evans <grknight@gentoo.org>2015-10-20 10:52:25 -0400
commit37a22f1242fb0c1e71cf4f6a7285553dcf25a66d (patch)
tree767585b388046ca262668a088b69664b60d85b22 /dev-db
parentmysql-multilib.eclass: Use has_version instead of built_with_use (diff)
downloadgentoo-37a22f1242fb0c1e71cf4f6a7285553dcf25a66d.tar.gz
gentoo-37a22f1242fb0c1e71cf4f6a7285553dcf25a66d.tar.bz2
gentoo-37a22f1242fb0c1e71cf4f6a7285553dcf25a66d.zip
dev-db/mysql: Add LibreSSL support
Package-Manager: portage-2.2.23
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/mysql/metadata.xml7
-rw-r--r--dev-db/mysql/mysql-5.6.26-r1.ebuild8
-rw-r--r--dev-db/mysql/mysql-5.6.26.ebuild8
-rw-r--r--dev-db/mysql/mysql-5.6.27-r1.ebuild8
-rw-r--r--dev-db/mysql/mysql-5.6.27.ebuild8
5 files changed, 39 insertions, 0 deletions
diff --git a/dev-db/mysql/metadata.xml b/dev-db/mysql/metadata.xml
index f5f14d5b85f2..c5f04ffb4438 100644
--- a/dev-db/mysql/metadata.xml
+++ b/dev-db/mysql/metadata.xml
@@ -2,6 +2,10 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>mysql</herd>
+ <maintainer restrict="dev-db/mysql[libressl]">
+ <email>hasufell@gentoo.org</email>
+ <description>Libressl issues. Only assign if it's a direct Libressl issue. Do not directly assign for anything else.</description>
+ </maintainer>
<!--
Please note that this list is shared between the following packages:
dev-db/mysql
@@ -15,6 +19,8 @@ dev-db/mariadb
<flag name='extraengine'>Add support for alternative storage engines (Archive, CSV, Blackhole, Federated(X), Partition)</flag>
<flag name="jemalloc">Use <pkg>dev-libs/jemalloc</pkg> for allocations.</flag>
<flag name='latin1'>Use LATIN1 encoding instead of UTF8</flag>
+ <flag name='libressl'>Enable SSL connections and crypto functions using <pkg>dev-libs/libressl</pkg></flag>
+ <flag name='openssl'>Enable SSL connections and crypto functions using <pkg>dev-libs/openssl</pkg></flag>
<flag name='max-idx-128'>Raise the max index per table limit from 64 to 128</flag>
<flag name='minimal'>Install client programs only, no server</flag>
<flag name='profiling'>Add support for statement profiling (requires USE=community).</flag>
@@ -22,5 +28,6 @@ dev-db/mariadb
<flag name="systemtap">Build support for profiling and tracing using <pkg>dev-util/systemtap</pkg></flag>
<flag name='test'>Install upstream testsuites for end use.</flag>
<flag name='tools'>Build the command line tools (mysql, mysqldump, mysqladmin, etc)</flag>
+ <flag name='yassl'>Enable SSL connections and crypto functions using the bundled yaSSL</flag>
</use>
</pkgmetadata>
diff --git a/dev-db/mysql/mysql-5.6.26-r1.ebuild b/dev-db/mysql/mysql-5.6.26-r1.ebuild
index 365c7de4ede6..4ff5c0d796e7 100644
--- a/dev-db/mysql/mysql-5.6.26-r1.ebuild
+++ b/dev-db/mysql/mysql-5.6.26-r1.ebuild
@@ -31,6 +31,14 @@ RDEPEND="${RDEPEND}"
# disable until we see what happens with it
MYSQL_CMAKE_NATIVE_DEFINES="-DWITHOUT_VALIDATE_PASSWORD=1"
+src_prepare() {
+ mysql-multilib_src_prepare
+ if use libressl ; then
+ sed -i 's/OPENSSL_MAJOR_VERSION STREQUAL "1"/OPENSSL_MAJOR_VERSION STREQUAL "2"/' \
+ "${S}/cmake/ssl.cmake" || die
+ fi
+}
+
# Official test instructions:
# USE='server embedded extraengine perl ssl static-libs community' \
# FEATURES='test userpriv -usersandbox' \
diff --git a/dev-db/mysql/mysql-5.6.26.ebuild b/dev-db/mysql/mysql-5.6.26.ebuild
index 689d4aee4db6..3235fd935839 100644
--- a/dev-db/mysql/mysql-5.6.26.ebuild
+++ b/dev-db/mysql/mysql-5.6.26.ebuild
@@ -30,6 +30,14 @@ RDEPEND="${RDEPEND}"
# disable until we see what happens with it
MYSQL_CMAKE_NATIVE_DEFINES="-DWITHOUT_VALIDATE_PASSWORD=1"
+src_prepare() {
+ mysql-multilib_src_prepare
+ if use libressl ; then
+ sed -i 's/OPENSSL_MAJOR_VERSION STREQUAL "1"/OPENSSL_MAJOR_VERSION STREQUAL "2"/' \
+ "${S}/cmake/ssl.cmake" || die
+ fi
+}
+
# Official test instructions:
# USE='embedded extraengine perl ssl static-libs community' \
# FEATURES='test userpriv -usersandbox' \
diff --git a/dev-db/mysql/mysql-5.6.27-r1.ebuild b/dev-db/mysql/mysql-5.6.27-r1.ebuild
index 365c7de4ede6..4ff5c0d796e7 100644
--- a/dev-db/mysql/mysql-5.6.27-r1.ebuild
+++ b/dev-db/mysql/mysql-5.6.27-r1.ebuild
@@ -31,6 +31,14 @@ RDEPEND="${RDEPEND}"
# disable until we see what happens with it
MYSQL_CMAKE_NATIVE_DEFINES="-DWITHOUT_VALIDATE_PASSWORD=1"
+src_prepare() {
+ mysql-multilib_src_prepare
+ if use libressl ; then
+ sed -i 's/OPENSSL_MAJOR_VERSION STREQUAL "1"/OPENSSL_MAJOR_VERSION STREQUAL "2"/' \
+ "${S}/cmake/ssl.cmake" || die
+ fi
+}
+
# Official test instructions:
# USE='server embedded extraengine perl ssl static-libs community' \
# FEATURES='test userpriv -usersandbox' \
diff --git a/dev-db/mysql/mysql-5.6.27.ebuild b/dev-db/mysql/mysql-5.6.27.ebuild
index e10fde2bb3d9..98a209a6630e 100644
--- a/dev-db/mysql/mysql-5.6.27.ebuild
+++ b/dev-db/mysql/mysql-5.6.27.ebuild
@@ -30,6 +30,14 @@ RDEPEND="${RDEPEND}"
# disable until we see what happens with it
MYSQL_CMAKE_NATIVE_DEFINES="-DWITHOUT_VALIDATE_PASSWORD=1"
+src_prepare() {
+ mysql-multilib_src_prepare
+ if use libressl ; then
+ sed -i 's/OPENSSL_MAJOR_VERSION STREQUAL "1"/OPENSSL_MAJOR_VERSION STREQUAL "2"/' \
+ "${S}/cmake/ssl.cmake" || die
+ fi
+}
+
# Official test instructions:
# USE='embedded extraengine perl ssl static-libs community' \
# FEATURES='test userpriv -usersandbox' \