summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorGeaaru <geaaru@gmail.com>2018-08-28 22:09:38 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-09-01 00:12:32 +0200
commit94b2b8a10c2b8710a6059eba385544e893621e4c (patch)
treefe13c7cfdf7a6392a6499e4091d2f1ed6058b6b6 /dev-db
parentmedia-gfx/opentoonz: remove unused patch. (diff)
downloadgentoo-94b2b8a10c2b8710a6059eba385544e893621e4c.tar.gz
gentoo-94b2b8a10c2b8710a6059eba385544e893621e4c.tar.bz2
gentoo-94b2b8a10c2b8710a6059eba385544e893621e4c.zip
dev-db/cpp-driver: version bump to 2.9.0.
Package-Manager: Portage-2.3.40, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/9723
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/cpp-driver/Manifest1
-rw-r--r--dev-db/cpp-driver/cpp-driver-2.9.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-db/cpp-driver/Manifest b/dev-db/cpp-driver/Manifest
index c75a4ea63d7a..ada7b3c97855 100644
--- a/dev-db/cpp-driver/Manifest
+++ b/dev-db/cpp-driver/Manifest
@@ -1 +1,2 @@
DIST cpp-driver-2.8.1.tar.gz 1526453 BLAKE2B 8ab4332f00a1da9f35be6fa8651ace54d71fbac76223c1665089096376dcfd6f5976beb83c25094f531786a4aa628aa4e288540ef7bcb8cc5221625dcd1ccf78 SHA512 1b303e874d6b24cb429ec92d6030880ad7d7b28b167a25c62060626c206f623863ecf58eab33e89b0efea4a474ca9500e1701b719ac203c76b0875c2b5d0a1c8
+DIST cpp-driver-2.9.0.tar.gz 9178108 BLAKE2B 22c51d050dc65303dd6b584f0a89e510905bf084ff5e45a543666675a4e0b904c11895c9a7dd3d0df2fb12c1e2e58e8530c4113706c8b2548adb0b6f9431419c SHA512 45c6d58b1d287d142c9d7d6b1e28114683648a3634f44b185208fa44da64d4c8a9d485b3956a0cf7429e96f74faa588de832de30265dfa17782ca90e8163a0c1
diff --git a/dev-db/cpp-driver/cpp-driver-2.9.0.ebuild b/dev-db/cpp-driver/cpp-driver-2.9.0.ebuild
new file mode 100644
index 000000000000..66d76de1def7
--- /dev/null
+++ b/dev-db/cpp-driver/cpp-driver-2.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="DataStax C/C++ Driver for Cassandra"
+HOMEPAGE="https://datastax.github.io/cpp-driver/"
+SRC_URI="https://github.com/datastax/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl ssl"
+
+RDEPEND="
+ dev-libs/libuv:=
+ ssl? (
+ !libressl? ( dev-libs/openssl:= )
+ libressl? ( dev-libs/libressl:= )
+ )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local mycmakeargs=( -DCASS_USE_OPENSSL=$(usex ssl) )
+ cmake-utils_src_configure
+}