summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2015-09-17 19:44:02 +0200
committerChristoph Mende <angelos@gentoo.org>2015-09-17 21:01:09 +0200
commit616c3fbad930a07f238ac5db8af1ec65fc8e6a72 (patch)
tree7c58927e381796f59138fb7257f3686036e9d3da /dev-dotnet/dbus-sharp-glib
parentdev-dotnet/dbus-sharp: version bump to 0.8.1 (diff)
downloadgentoo-616c3fbad930a07f238ac5db8af1ec65fc8e6a72.tar.gz
gentoo-616c3fbad930a07f238ac5db8af1ec65fc8e6a72.tar.bz2
gentoo-616c3fbad930a07f238ac5db8af1ec65fc8e6a72.zip
dev-dotnet/dbus-sharp-glib: version bump to 0.6.0
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'dev-dotnet/dbus-sharp-glib')
-rw-r--r--dev-dotnet/dbus-sharp-glib/Manifest1
-rw-r--r--dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.6.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-dotnet/dbus-sharp-glib/Manifest b/dev-dotnet/dbus-sharp-glib/Manifest
index 37a07db0e875..77de76fac86b 100644
--- a/dev-dotnet/dbus-sharp-glib/Manifest
+++ b/dev-dotnet/dbus-sharp-glib/Manifest
@@ -1 +1,2 @@
DIST dbus-sharp-glib-0.5.0.tar.gz 95405 SHA256 f4fd663957f06ac5f0322beab264c5498bf6408f7435d0387950b4cb7996180e SHA512 651a8d9b42342d6aca6b7963a089e8da609f0d2e9d6421f40fb9589204af63e790f1bc5dd7735bb751f84d3f0d888e2e2f174c23f79206f8858e0502cba95065 WHIRLPOOL 2d5776e367757e4a06b34e0b114b95e61b4a8dea54b60029d59c73802bf58e58c198cea5cd6094371a584ee54317f9fd9fb60e63a9b483311014498084155d8e
+DIST dbus-sharp-glib-0.6.0.tar.gz 73675 SHA256 d5b44d3ffa419730df0a6a6fff1e6912c80bc364e4176444e48264853989ce3b SHA512 271edf10d149e152290cd0ac8ebaf6ed7a6f5d0f280d5514dbfbdb84f77d8339ba0e2c5fd53242cf00e13c7d2bfa3fbf426ca9038467b26b9a8396c6c9c1ed67 WHIRLPOOL 18d976f9aaf53d992195ddcdae3f7a37224119a34ad7ed2a5c66cc302aac111d928461432244950ffee8527082010826bb7cdbf0ad66b263dc600243997054cb
diff --git a/dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.6.0.ebuild b/dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.6.0.ebuild
new file mode 100644
index 000000000000..20b83d315719
--- /dev/null
+++ b/dev-dotnet/dbus-sharp-glib/dbus-sharp-glib-0.6.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools mono-env
+
+DESCRIPTION="D-Bus for .NET: GLib integration module"
+HOMEPAGE="https://github.com/mono/dbus-sharp"
+SRC_URI="https://github.com/mono/${PN}/releases/download/v${PV%.*}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/mono
+ >=dev-dotnet/dbus-sharp-0.8"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+pkg_setup() {
+ DOCS="AUTHORS README"
+ mono-env_pkg_setup
+}
+
+src_prepare() {
+ sed -i -e 's/gmcs/mcs/' configure.ac || die
+ eautoreconf
+}