summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-dotnet/ikvm-bin/ikvm-bin-7.1.4532.2.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-dotnet/ikvm-bin/ikvm-bin-7.1.4532.2.ebuild')
-rw-r--r--dev-dotnet/ikvm-bin/ikvm-bin-7.1.4532.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/dev-dotnet/ikvm-bin/ikvm-bin-7.1.4532.2.ebuild b/dev-dotnet/ikvm-bin/ikvm-bin-7.1.4532.2.ebuild
new file mode 100644
index 000000000000..16dcaa8d1d65
--- /dev/null
+++ b/dev-dotnet/ikvm-bin/ikvm-bin-7.1.4532.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils mono multilib
+
+MY_P=${P/-bin/}
+MY_PN=${PN/-bin/}
+
+DESCRIPTION="Java VM for .NET"
+HOMEPAGE="http://www.ikvm.net/ http://weblog.ikvm.net/"
+SRC_URI="http://www.frijters.net/${MY_PN}bin-${PV}.zip"
+LICENSE="ZLIB GPL-2-with-linking-exception"
+
+SLOT="0"
+S=${WORKDIR}/${MY_P}
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/mono-1.1
+ !dev-dotnet/ikvm
+ app-arch/unzip"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ insinto /usr/$(get_libdir)/${MY_PN}
+ doins bin/*
+
+ for exe in ikvm ikvmc ikvmstub;
+ do
+ make_wrapper ${exe} "mono /usr/$(get_libdir)/${MY_PN}/${exe}.exe" || die
+ done
+
+ dodir /usr/$(get_libdir)/pkgconfig
+ sed -e "s:@VERSION@:${PV}:" \
+ -e "s:@LIBDIR@:$(get_libdir):" \
+ "${FILESDIR}"/ikvm-0.36.0.5.pc.in > "${D}"/usr/$(get_libdir)/pkgconfig/${MY_PN}.pc \
+ || die "sed failed"
+
+ for dll in bin/IKVM*.dll
+ do
+ dllbase=${dll##*/}
+ ebegin "Installing and registering ${dllbase}"
+ gacutil -i bin/${dllbase} -root "${D}"/usr/$(get_libdir) \
+ -gacdir /usr/$(get_libdir) -package IKVM &>/dev/null
+ eend $? || die "Failed installing ${dllbase}"
+ done
+}