summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-09 10:43:25 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-09 11:03:45 +0200
commit3fdfcfa70f768c67f7cf080424c7f83ace30efe4 (patch)
tree244b176aff47c6ade92f20a985cf0a12b77fe429 /dev-dotnet/ndesk-dbus-glib
parentdev-dotnet/ndesk-dbus: Add die statement (diff)
downloadgentoo-3fdfcfa70f768c67f7cf080424c7f83ace30efe4.tar.gz
gentoo-3fdfcfa70f768c67f7cf080424c7f83ace30efe4.tar.bz2
gentoo-3fdfcfa70f768c67f7cf080424c7f83ace30efe4.zip
dev-dotnet/ndesk-dbus-glib: Fix compat with mono-4
Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-dotnet/ndesk-dbus-glib')
-rw-r--r--dev-dotnet/ndesk-dbus-glib/ndesk-dbus-glib-0.4.1.ebuild27
1 files changed, 14 insertions, 13 deletions
diff --git a/dev-dotnet/ndesk-dbus-glib/ndesk-dbus-glib-0.4.1.ebuild b/dev-dotnet/ndesk-dbus-glib/ndesk-dbus-glib-0.4.1.ebuild
index 3cec3cf01868..93a4d59e99b7 100644
--- a/dev-dotnet/ndesk-dbus-glib/ndesk-dbus-glib-0.4.1.ebuild
+++ b/dev-dotnet/ndesk-dbus-glib/ndesk-dbus-glib-0.4.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=3
-inherit mono multilib
+EAPI=6
+inherit mono-env
DESCRIPTION="glib integration for DBus-Sharp"
HOMEPAGE="http://www.ndesk.org/DBusSharp"
@@ -12,17 +12,18 @@ SRC_URI="http://www.ndesk.org/archive/dbus-sharp/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ppc x86"
-IUSE="debug"
+IUSE=""
-RDEPEND=">=dev-lang/mono-1.2.4
- >=dev-dotnet/ndesk-dbus-0.4"
+RDEPEND="
+ >=dev-lang/mono-1.2.4
+ >=dev-dotnet/ndesk-dbus-0.4
+"
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
-src_compile() {
- emake || die "make failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
+src_prepare() {
+ default
+ # mono-4 compat
+ sed -i "s#gmcs#mcs#g" configure || die
}