summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-embedded/avra
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-embedded/avra')
-rw-r--r--dev-embedded/avra/Manifest1
-rw-r--r--dev-embedded/avra/avra-1.3.0.ebuild41
-rw-r--r--dev-embedded/avra/metadata.xml15
3 files changed, 57 insertions, 0 deletions
diff --git a/dev-embedded/avra/Manifest b/dev-embedded/avra/Manifest
new file mode 100644
index 000000000000..2cf0676f28a7
--- /dev/null
+++ b/dev-embedded/avra/Manifest
@@ -0,0 +1 @@
+DIST avra-1.3.0.tar.bz2 314903 SHA256 a62cbf8662caf9cc4e75da6c634efce402778639202a65eb2d149002c1049712 SHA512 4215b87379a6c2a9b81048dfd717a05881e2dc38359e49812be44bb64ac3e45911367fdf73f0c9f753e67e9ea23d19f33365dc4140ec94d13f1d8077b978fb93 WHIRLPOOL 58b67d129eb839a80d8b7aad0e580e022dd488c0dc9f9197d32ee65c0a5f24067c4db82691d5e9511b8619f7c63e082c856c824ecc30f2d9c410dc40459df602
diff --git a/dev-embedded/avra/avra-1.3.0.ebuild b/dev-embedded/avra/avra-1.3.0.ebuild
new file mode 100644
index 000000000000..4c5910591cab
--- /dev/null
+++ b/dev-embedded/avra/avra-1.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools
+
+DESCRIPTION="Atmel AVR Assembler"
+HOMEPAGE="http://avra.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="doc examples"
+
+S="${WORKDIR}/${P}/src/"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_install() {
+ local datadir="${WORKDIR}/${P}"
+
+ default
+
+ dodoc ${datadir}/{AUTHORS,INSTALL,README,TODO}
+
+ # install headers
+ insinto /usr/include/avr
+ doins "${datadir}/includes/"*
+
+ use doc && dohtml -r "${datadir}/doc/"*
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins "${datadir}/examples/"*
+ fi
+}
diff --git a/dev-embedded/avra/metadata.xml b/dev-embedded/avra/metadata.xml
new file mode 100644
index 000000000000..a4645995f39e
--- /dev/null
+++ b/dev-embedded/avra/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>raxas@pavouk-v-rohu.net</email>
+ <name>Petr Kocmid</name>
+ </maintainer>
+ <longdescription lang="en">
+ Assembler for Atmel AVR microprocessors
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">avra</remote-id>
+ </upstream>
+</pkgmetadata>