summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-12-25 11:24:02 +0100
committerDavid Seifert <soap@gentoo.org>2017-12-25 11:42:52 +0100
commit0e53e7374ad68a0ce6ade031bdbf34294e38d39f (patch)
tree44fbc18e5bce21a57d27f9ab8a8cfa03e2874408 /dev-embedded
parentkde-apps/ksmtp: Drop old (diff)
downloadgentoo-0e53e7374ad68a0ce6ade031bdbf34294e38d39f.tar.gz
gentoo-0e53e7374ad68a0ce6ade031bdbf34294e38d39f.tar.bz2
gentoo-0e53e7374ad68a0ce6ade031bdbf34294e38d39f.zip
dev-embedded/libftdi: [QA] Run cmake-utils_src_prepare
Closes: https://bugs.gentoo.org/640204 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/libftdi/libftdi-0.19.ebuild4
-rw-r--r--dev-embedded/libftdi/libftdi-0.20-r1.ebuild13
-rw-r--r--dev-embedded/libftdi/libftdi-1.2-r1.ebuild7
-rw-r--r--dev-embedded/libftdi/libftdi-1.2-r2.ebuild5
-rw-r--r--dev-embedded/libftdi/libftdi-9999.ebuild5
5 files changed, 17 insertions, 17 deletions
diff --git a/dev-embedded/libftdi/libftdi-0.19.ebuild b/dev-embedded/libftdi/libftdi-0.19.ebuild
index 69ea48c31b00..71475c707666 100644
--- a/dev-embedded/libftdi/libftdi-0.19.ebuild
+++ b/dev-embedded/libftdi/libftdi-0.19.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="2"
if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3 autotools
EGIT_REPO_URI="git://developer.intra2net.com/${PN}"
- inherit git-2 autotools
else
SRC_URI="http://www.intra2net.com/en/developer/${PN}/download/${P}.tar.gz"
KEYWORDS="amd64 arm ppc ppc64 sparc x86"
diff --git a/dev-embedded/libftdi/libftdi-0.20-r1.ebuild b/dev-embedded/libftdi/libftdi-0.20-r1.ebuild
index 87f52c9e3e58..8aed5262ba38 100644
--- a/dev-embedded/libftdi/libftdi-0.20-r1.ebuild
+++ b/dev-embedded/libftdi/libftdi-0.20-r1.ebuild
@@ -7,8 +7,8 @@ PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 )
inherit cmake-utils python-single-r1
if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
EGIT_REPO_URI="git://developer.intra2net.com/${PN}"
- inherit git-2
else
SRC_URI="http://www.intra2net.com/en/developer/${PN}/download/${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
@@ -20,6 +20,7 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="0"
IUSE="cxx doc examples python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="virtual/libusb:0
cxx? ( dev-libs/boost )
@@ -28,7 +29,10 @@ DEPEND="${RDEPEND}
python? ( dev-lang/swig )
doc? ( app-doc/doxygen )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+PATCHES=(
+ "${FILESDIR}"/${P}-cmake-include.patch
+ "${FILESDIR}"/${P}-cmake-version.patch
+)
pkg_setup() {
use python && python-single-r1_pkg_setup
@@ -44,12 +48,11 @@ src_prepare() {
-e '/SET(LIB_SUFFIX /d' \
CMakeLists.txt || die
- eapply "${FILESDIR}"/${P}-cmake-{include,version}.patch
- eapply_user
+ cmake-utils_src_prepare
}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DFTDIPP=$(usex cxx)
-DDOCUMENTATION=$(usex doc)
-DEXAMPLES=$(usex examples)
diff --git a/dev-embedded/libftdi/libftdi-1.2-r1.ebuild b/dev-embedded/libftdi/libftdi-1.2-r1.ebuild
index 8c4d73cf0ed8..9ca55beeaad6 100644
--- a/dev-embedded/libftdi/libftdi-1.2-r1.ebuild
+++ b/dev-embedded/libftdi/libftdi-1.2-r1.ebuild
@@ -8,8 +8,8 @@ inherit cmake-utils python-single-r1
MY_P="${PN}1-${PV}"
if [[ ${PV} == 9999* ]] ; then
+ inherit git-r3
EGIT_REPO_URI="git://developer.intra2net.com/${PN}"
- inherit git-2
else
SRC_URI="http://www.intra2net.com/en/developer/${PN}/download/${MY_P}.tar.bz2"
KEYWORDS="amd64 arm arm64 ~mips ppc ppc64 sparc x86"
@@ -21,6 +21,7 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="1"
IUSE="cxx doc examples python static-libs test tools"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="virtual/libusb:1
cxx? ( dev-libs/boost )
@@ -33,8 +34,6 @@ DEPEND="${RDEPEND}
python? ( dev-lang/swig )
doc? ( app-doc/doxygen )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}
@@ -42,7 +41,7 @@ pkg_setup() {
S=${WORKDIR}/${MY_P}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DFTDIPP=$(usex cxx)
-DDOCUMENTATION=$(usex doc)
-DEXAMPLES=$(usex examples)
diff --git a/dev-embedded/libftdi/libftdi-1.2-r2.ebuild b/dev-embedded/libftdi/libftdi-1.2-r2.ebuild
index c52061be670e..e35ae39feab1 100644
--- a/dev-embedded/libftdi/libftdi-1.2-r2.ebuild
+++ b/dev-embedded/libftdi/libftdi-1.2-r2.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="1"
IUSE="cxx doc examples python static-libs test tools"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="virtual/libusb:1
cxx? ( dev-libs/boost )
@@ -33,8 +34,6 @@ DEPEND="${RDEPEND}
python? ( dev-lang/swig )
doc? ( app-doc/doxygen )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}
@@ -42,7 +41,7 @@ pkg_setup() {
S=${WORKDIR}/${MY_P}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DFTDIPP=$(usex cxx)
-DDOCUMENTATION=$(usex doc)
-DEXAMPLES=$(usex examples)
diff --git a/dev-embedded/libftdi/libftdi-9999.ebuild b/dev-embedded/libftdi/libftdi-9999.ebuild
index c52061be670e..e35ae39feab1 100644
--- a/dev-embedded/libftdi/libftdi-9999.ebuild
+++ b/dev-embedded/libftdi/libftdi-9999.ebuild
@@ -21,6 +21,7 @@ HOMEPAGE="http://www.intra2net.com/en/developer/libftdi/"
LICENSE="LGPL-2"
SLOT="1"
IUSE="cxx doc examples python static-libs test tools"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="virtual/libusb:1
cxx? ( dev-libs/boost )
@@ -33,8 +34,6 @@ DEPEND="${RDEPEND}
python? ( dev-lang/swig )
doc? ( app-doc/doxygen )"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
-
pkg_setup() {
use python && python-single-r1_pkg_setup
}
@@ -42,7 +41,7 @@ pkg_setup() {
S=${WORKDIR}/${MY_P}
src_configure() {
- mycmakeargs=(
+ local mycmakeargs=(
-DFTDIPP=$(usex cxx)
-DDOCUMENTATION=$(usex doc)
-DEXAMPLES=$(usex examples)