summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-12-13 10:01:11 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-12-13 10:01:11 +0300
commit482b187c4522a8a74435fe626bf5f1835b8eb31d (patch)
treeda520d6535d1afe2630c343ff89672edd87b67ed /dev-embedded
parentapp-portage/eix: Version bump (v0.33.9) (diff)
downloadgentoo-482b187c4522a8a74435fe626bf5f1835b8eb31d.tar.gz
gentoo-482b187c4522a8a74435fe626bf5f1835b8eb31d.tar.bz2
gentoo-482b187c4522a8a74435fe626bf5f1835b8eb31d.zip
dev-embedded/u-boot-tools: Version bump (v2019.10)
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/u-boot-tools/Manifest1
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2019.10.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-embedded/u-boot-tools/Manifest b/dev-embedded/u-boot-tools/Manifest
index 4d7d550ba90b..8ee02d5e7136 100644
--- a/dev-embedded/u-boot-tools/Manifest
+++ b/dev-embedded/u-boot-tools/Manifest
@@ -1,3 +1,4 @@
DIST u-boot-2018.05.tar.bz2 12469276 BLAKE2B b09189d9bf8554c21630d42024d64894270c02e3efa8046bc2bef0efd68b9e0a02c3290228ffb71a4bab524d46111e32adb492c3ce9a3ef1be32287a3bbdb36a SHA512 218f71282c9d027b0faf210ce2d4d713779e0c61ea4a23f03d5dec0ca8836a3c26b46c5e258d583834f5b5a2f4663f98729ca4b0101a60f85457eb892f8370d2
DIST u-boot-2018.11.tar.bz2 13045125 BLAKE2B d2522e1eb2fb899f1217261b6c311be35ae2fb01d187714311184e6f913d1d5b3ad953b5fa02c5c7b0e1e5981be101ce82ea4cf09a457d32d778ffa5cadc0786 SHA512 1ea0bbb5f5e6d4c60b3a6bd345d1fa6e9da025daf36f47e8392bab34cb432c2e3633d903efb260f71fff87dffd6f2bf09ac900e96b3d4247073958d83b89ceff
DIST u-boot-2019.01.tar.bz2 13366005 BLAKE2B 161d927d5f2cb38c6a930f0b5edfedeb3a93586ea98e03066a1fa9c516bfc1f6ab8d5ba60b36714d10c08232971e7a0987f4d0a05635fa14a6359bb120aa0ed2 SHA512 d9699cd22afe9bc747d64208068c2cf8a2c3143d161ede24536f6fd6adfd6b81e28920589722639e2e48fcf34e8dbde3ead7f691f14cbcc38cd75694d14d719b
+DIST u-boot-2019.10.tar.bz2 14214608 BLAKE2B 0dc89ebe207f836d2430d5111def9b4efa22839311d28cbfe4f0387a1b211850b0bf3cd67440b3cc32fb23aa8ece270c2438c44f5432f72474b4802ff117e803 SHA512 d8e98fca4b6af8d49d20ec09beab16b77863fcee88cda3605cc14435de21030bf3ca5e7cf7d06e42d4c0f75279c7295ecd628d2b77666eff7b7fd50374e051fd
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2019.10.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2019.10.ebuild
new file mode 100644
index 000000000000..e0e563ba9537
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2019.10.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="
+ sys-devel/flex
+ sys-devel/bison
+"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ # Unset a few KBUILD variables. Bug #540476
+ unset KBUILD_OUTPUT KBUILD_SRC
+
+ emake \
+ V=1 \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ tools-only_defconfig
+
+ emake \
+ V=1 \
+ NO_SDL=1 \
+ HOSTSTRIP=: \
+ STRIP=: \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ CONFIG_ENV_OVERWRITE=y \
+ tools-all
+}
+
+src_test() { :; }
+
+src_install() {
+ cd tools || die
+ dobin bmp_logo dumpimage fdtgrep gen_eth_addr img2srec mkenvimage mkimage
+ dobin easylogo/easylogo
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+ doman "${S}"/doc/mkimage.1
+}