summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-games/hdl_dump
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-games/hdl_dump')
-rw-r--r--dev-games/hdl_dump/Manifest1
-rw-r--r--dev-games/hdl_dump/files/hdl_dump-0.8.6.20060901-fortify.patch45
-rw-r--r--dev-games/hdl_dump/hdl_dump-0.8.6.20060901.ebuild32
-rw-r--r--dev-games/hdl_dump/metadata.xml8
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-games/hdl_dump/Manifest b/dev-games/hdl_dump/Manifest
new file mode 100644
index 000000000000..daf0fc53bb0e
--- /dev/null
+++ b/dev-games/hdl_dump/Manifest
@@ -0,0 +1 @@
+DIST hdl_dumx-0.8.6-20060901-src.tar.bz2 156322 SHA256 6ccb427da1fb957d82e6e0929e3605abe136f44326e85b16b6cdc3b59569486b SHA512 c54c72c3f4d57ca8f3299c0b6044ec5376504f7b7a4c7977d71b996bc8d98577ffa868891e1a599aebbe58b8d3ccf2513c5cf8a47350c0b0f53fd21a0e64bbc8 WHIRLPOOL b70135fb6e663db1016dfd8db5519c33b31e9e8b1ba219c72f513cab6d158564c9bcaa6886ce06b7ae3d75976b4a3f1b49561c799bbda80bda84cf378e017aa2
diff --git a/dev-games/hdl_dump/files/hdl_dump-0.8.6.20060901-fortify.patch b/dev-games/hdl_dump/files/hdl_dump-0.8.6.20060901-fortify.patch
new file mode 100644
index 000000000000..96f85d4609af
--- /dev/null
+++ b/dev-games/hdl_dump/files/hdl_dump-0.8.6.20060901-fortify.patch
@@ -0,0 +1,45 @@
+http://bugs.gentoo.org/340145
+
+fix buffer overflows in path handling. these defines should only be used
+with host paths, so bumping them up to a larger value should be fine.
+
+--- a/common.h
++++ b/common.h
+@@ -35,7 +35,8 @@
+ C_START
+
+ #if !defined (MAX_PATH)
+-# define MAX_PATH 128
++/* This needs to be at least 256 bytes -- see iin_gi_probe_path */
++# define MAX_PATH 1024
+ #endif
+
+
+--- a/osal.h
++++ b/osal.h
+@@ -62,7 +62,8 @@ typedef struct
+ # define OSAL_HANDLE_INIT { -1 } /* file descriptor */
+ # define OSAL_IS_OPENED(x) ((x).desc != -1)
+
+-# define MAX_PATH 256
++/* This needs to be at least 256 bytes -- see iin_gi_probe_path */
++# define MAX_PATH 1024
+
+ #endif
+ typedef /*@special@*/ /*@only@*/ /*@out@*/ osal_handle_t* osal_handle_p_t;
+
+the magic field is 32 bytes, so strcpy-ing 32 bytes will add a 33rd NUL char.
+this isn't a problem in practice as the 33rd char is "unknown_0x02", but let's
+fix the issue anyways.
+
+--- a/apa.c
++++ b/apa.c
+@@ -1270,7 +1270,7 @@ apa_initialize_ex (hio_t *hio)
+ set_u32 (&header.length, 128 * 1024 * 2);
+ set_u16 (&header.type, 0x0001);
+ set_ps2fs_datetime (&header.created, time (NULL));
+- strcpy (header.mbr.magic, "Sony Computer Entertainment Inc.");
++ memcpy (header.mbr.magic, "Sony Computer Entertainment Inc.", 32);
+ header.mbr.unknown_0x02 = 0x02;
+ set_ps2fs_datetime (&header.mbr.created, time (NULL));
+ set_u32 (&header.checksum, apa_partition_checksum (&header));
diff --git a/dev-games/hdl_dump/hdl_dump-0.8.6.20060901.ebuild b/dev-games/hdl_dump/hdl_dump-0.8.6.20060901.ebuild
new file mode 100644
index 000000000000..52273a3e821c
--- /dev/null
+++ b/dev-games/hdl_dump/hdl_dump-0.8.6.20060901.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs versionator
+
+MY_PV=$(replace_version_separator 3 -)
+DESCRIPTION="game installer for playstation 2 HD Loader"
+HOMEPAGE="http://www.psx-scene.com/hdldump/"
+SRC_URI="http://www.psx-scene.com/hdldump/hdl_dumx-${MY_PV}-src.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-fortify.patch #340145
+ sed -i \
+ -e "s/-O0 -g/${CFLAGS}/" \
+ -e "s/@\$(CC)/$(tc-getCC)/" \
+ -e '/LDFLAGS =/d' \
+ Makefile || die
+}
+
+src_install() {
+ dobin hdl_dump
+ dodoc AUTHORS CHANGELOG README TODO
+}
diff --git a/dev-games/hdl_dump/metadata.xml b/dev-games/hdl_dump/metadata.xml
new file mode 100644
index 000000000000..ea461f64c94c
--- /dev/null
+++ b/dev-games/hdl_dump/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+ <email>vapier@gentoo.org</email>
+</maintainer>
+</pkgmetadata>