summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2020-12-03 23:10:42 +1100
committerMichael Palimaka <kensington@gentoo.org>2020-12-03 23:11:11 +1100
commit6abcde08e0d3391c4b5a3cc9e83569dfdd0be76f (patch)
tree2c4a6e35d53f8af15abffa134e5763ab9110828d /dev-games/tiled
parentprofiles/arch/riscv: mask input flasgs for xorg-drivers (diff)
downloadgentoo-6abcde08e0d3391c4b5a3cc9e83569dfdd0be76f.tar.gz
gentoo-6abcde08e0d3391c4b5a3cc9e83569dfdd0be76f.tar.bz2
gentoo-6abcde08e0d3391c4b5a3cc9e83569dfdd0be76f.zip
dev-games/tiled: fix plugin loading, add python3.8 support
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'dev-games/tiled')
-rw-r--r--dev-games/tiled/files/tiled-1.4.3-python-38.patch14
-rw-r--r--dev-games/tiled/tiled-1.4.3-r1.ebuild73
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-games/tiled/files/tiled-1.4.3-python-38.patch b/dev-games/tiled/files/tiled-1.4.3-python-38.patch
new file mode 100644
index 000000000000..5515fa8fff2f
--- /dev/null
+++ b/dev-games/tiled/files/tiled-1.4.3-python-38.patch
@@ -0,0 +1,14 @@
+--- a/src/plugins/python/find_python.pri
++++ b/src/plugins/python/find_python.pri
+@@ -1,6 +1,10 @@
+ !contains(DISABLE_PYTHON_PLUGIN, yes) {
+ unix {
+- packagesExist(python3) {
++ packagesExist(python3-embed) {
++ HAVE_PYTHON = yes
++ CONFIG += link_pkgconfig
++ PKGCONFIG += python3-embed
++ } else:packagesExist(python3) {
+ HAVE_PYTHON = yes
+ CONFIG += link_pkgconfig
+ PKGCONFIG += python3
diff --git a/dev-games/tiled/tiled-1.4.3-r1.ebuild b/dev-games/tiled/tiled-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..0a20032a23ba
--- /dev/null
+++ b/dev-games/tiled/tiled-1.4.3-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-single-r1 qmake-utils xdg-utils
+
+DESCRIPTION="A general purpose tile map editor"
+HOMEPAGE="https://www.mapeditor.org/"
+SRC_URI="https://github.com/bjorn/tiled/archive/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples python"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ app-arch/zstd:=
+ >=dev-qt/qtcore-5.14:5
+ >=dev-qt/qtdeclarative-5.14:5
+ >=dev-qt/qtgui-5.14:5
+ >=dev-qt/qtnetwork-5.14:5
+ >=dev-qt/qtwidgets-5.14:5
+ sys-libs/zlib
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools:5
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS COPYING NEWS.md README.md )
+PATCHES=( "${FILESDIR}/${P}-python-38.patch" )
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ eqmake5 \
+ LIBDIR="/usr/$(get_libdir)" \
+ PREFIX="/usr" \
+ SYSTEM_ZSTD="yes" \
+ DISABLE_PYTHON_PLUGIN="$(usex !python)" \
+ USE_FHS_PLUGIN_PATH="true"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+
+ einstalldocs
+
+ if use examples ; then
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r examples
+ fi
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+}