summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:57:03 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-12-18 04:57:03 -0500
commit255e23d6e0d984e2f3489e2a6ae92df22e60b2e4 (patch)
tree5e9f79331d94d268b934cc8cf5f729affe250d63 /dev-games
parentEAPI=5 (diff)
downloadgentoo-255e23d6e0d984e2f3489e2a6ae92df22e60b2e4.tar.gz
gentoo-255e23d6e0d984e2f3489e2a6ae92df22e60b2e4.tar.bz2
gentoo-255e23d6e0d984e2f3489e2a6ae92df22e60b2e4.zip
EAPI=5; minor tidying
Package-Manager: portage-2.2.24
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/wfmath/wfmath-1.0.1.ebuild20
1 files changed, 7 insertions, 13 deletions
diff --git a/dev-games/wfmath/wfmath-1.0.1.ebuild b/dev-games/wfmath/wfmath-1.0.1.ebuild
index 10ad211a472d..77a2ab231ca6 100644
--- a/dev-games/wfmath/wfmath-1.0.1.ebuild
+++ b/dev-games/wfmath/wfmath-1.0.1.ebuild
@@ -2,7 +2,9 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
+inherit eutils
+
DESCRIPTION="Worldforge math library"
HOMEPAGE="http://www.worldforge.org/dev/eng/libraries/wfmath"
SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
@@ -17,24 +19,16 @@ DEPEND="doc? ( app-doc/doxygen )
virtual/pkgconfig"
src_configure() {
- econf \
- $(use_enable static-libs static)
+ econf $(use_enable static-libs static)
}
src_compile() {
emake
- if use doc; then
- emake -C doc docs
- fi
+ use doc && emake -C doc docs
}
src_install() {
default
- if use doc; then
- dohtml doc/html/*
- fi
- if ! use static-libs ; then
- find "${D}" -type f -name '*.la' -exec rm {} + \
- || die "la removal failed"
- fi
+ use doc && dohtml doc/html/*
+ prune_libtool_files
}