summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2016-03-31 00:50:48 -0700
committerZac Medico <zmedico@gentoo.org>2016-03-31 00:54:58 -0700
commit2e2c1f402085a6a19c259a51642bbdf4fe5cd72b (patch)
treeaec47b2a8d6951e2a3982e0c970c7c4e00e2219c /dev-go
parentgames-action/garden: build with gcc5 (bug #572672) (diff)
downloadgentoo-2e2c1f402085a6a19c259a51642bbdf4fe5cd72b.tar.gz
gentoo-2e2c1f402085a6a19c259a51642bbdf4fe5cd72b.tar.bz2
gentoo-2e2c1f402085a6a19c259a51642bbdf4fe5cd72b.zip
dev-go/go-crypto: fix tests for bug 577908
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-crypto/go-crypto-0_pre20160126.ebuild24
1 files changed, 9 insertions, 15 deletions
diff --git a/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild b/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild
index 79bc5a25836a..799b98bf93b5 100644
--- a/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild
+++ b/dev-go/go-crypto/go-crypto-0_pre20160126.ebuild
@@ -24,25 +24,19 @@ IUSE=""
DEPEND=""
RDEPEND=""
-src_prepare() {
- # disable broken tests
- sed -e 's:TestAgentForward(:_\0:' \
- -i src/${EGO_SRC}/ssh/test/agent_unix_test.go || die
- sed -e 's:TestRunCommandSuccess(:_\0:' \
- -e 's:TestRunCommandStdin(:_\0:' \
- -e 's:TestRunCommandStdinError(:_\0:' \
- -e 's:TestRunCommandWeClosed(:_\0:' \
- -e 's:TestFuncLargeRead(:_\0:' \
- -e 's:TestKeyChange(:_\0:' \
- -e 's:TestValidTerminalMode(:_\0:' \
- -i src/${EGO_SRC}/ssh/test/session_test.go || die
-}
-
src_compile() {
# Create a writable GOROOT in order to avoid sandbox violations.
cp -sR "$(go env GOROOT)" "${T}/goroot" || die
rm -rf "${T}/goroot/src/${EGO_SRC}" || die
rm -rf "${T}/goroot/pkg/$(go env GOOS)_$(go env GOARCH)/${EGO_SRC}" || die
export GOROOT="${T}/goroot"
- golang-build_src_compile
+ # Exclude $(get_golibdir_gopath) from GOPATH, for bug 577908 which may
+ # or may not manifest, depending on what libraries are installed.
+ export GOPATH="${WORKDIR}/${P}"
+ go install -v -work -x ${EGO_BUILD_FLAGS} "${EGO_PN}" || die
+}
+
+src_test() {
+ # Exclude $(get_golibdir_gopath) from GOPATH
+ go test -v -work -x "${EGO_PN}"
}