summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/extra
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/extra')
-rw-r--r--dev-haskell/extra/Manifest2
-rw-r--r--dev-haskell/extra/extra-1.3.1.ebuild27
-rw-r--r--dev-haskell/extra/extra-1.46.1-r1.ebuild44
-rw-r--r--dev-haskell/extra/metadata.xml8
4 files changed, 81 insertions, 0 deletions
diff --git a/dev-haskell/extra/Manifest b/dev-haskell/extra/Manifest
new file mode 100644
index 000000000000..f8e49952dd0f
--- /dev/null
+++ b/dev-haskell/extra/Manifest
@@ -0,0 +1,2 @@
+DIST Extra-1.46.1.tar.gz 19066 SHA256 e95b5bfcc770fc9f54edcf002055690537df7763cd5d78ba190c5660b438f235 SHA512 cf222ccac42e899d6af75980e30e46a6ea41217174262060b41972cb9925f54f15f71050055731f5978c44d7c0eb0d2e32b45e153130b11656590cc132f719b6 WHIRLPOOL 0dc1842de0ab87d9cfdbd98d15582609028c74f0fbc954693404e9c134e6d804cc2a523621288bd88041a9c4cb9c4af3358a60a7e4f07c961d62594181705700
+DIST extra-1.3.1.tar.gz 30439 SHA256 94c8cc02b530e589171d2e0520afac066994a1cb48cd4c847496387489230dfa SHA512 d6e736a021ee39139855516647b91a328e8ff075b94bdcc84c1296586d9f58a20819fcf78a45bd0fc9b3e9516780c68fb27ec0dc406964b6d9d5c93e26bfc9c5 WHIRLPOOL f8d02f3cd149f3d1dd5e30a5411f3359a2e4590061856f8f0350e63b4baafa961ade1ca142696dd1b1db97dc7ec35dc5481e836a4eaaf62803f55cf66b40caac
diff --git a/dev-haskell/extra/extra-1.3.1.ebuild b/dev-haskell/extra/extra-1.3.1.ebuild
new file mode 100644
index 000000000000..de600749bd20
--- /dev/null
+++ b/dev-haskell/extra/extra-1.3.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Extra functions I use"
+HOMEPAGE="https://github.com/ndmitchell/extra#readme"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+# this package has nothing to do with extra:0 (aka Extra on hackage)
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.10
+ test? ( dev-haskell/quickcheck )
+"
diff --git a/dev-haskell/extra/extra-1.46.1-r1.ebuild b/dev-haskell/extra/extra-1.46.1-r1.ebuild
new file mode 100644
index 000000000000..9c3daecfe41d
--- /dev/null
+++ b/dev-haskell/extra/extra-1.46.1-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="Extra"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A grab bag of modules"
+HOMEPAGE="http://src.seereason.com/haskell-extra"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-haskell/bzlib:=[profile?]
+ dev-haskell/hunit:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ >=dev-haskell/network-2.4:=[profile?]
+ dev-haskell/network-uri:=[profile?]
+ dev-haskell/puremd5:=[profile?]
+ =dev-haskell/quickcheck-2*:2=[profile?]
+ dev-haskell/random:=[profile?]
+ dev-haskell/regex-compat:=[profile?]
+ >=dev-haskell/unixutils-1.51:=[profile?]
+ dev-haskell/zlib:=[profile?]
+ >=dev-lang/ghc-6.12.1:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-0"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cabal_chdeps \
+ 'network >= 2.4' 'network >= 2.4, network-uri'
+}
diff --git a/dev-haskell/extra/metadata.xml b/dev-haskell/extra/metadata.xml
new file mode 100644
index 000000000000..dec238c397cb
--- /dev/null
+++ b/dev-haskell/extra/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ A hodge-podge of functions and modules that do not have a better home
+ </longdescription>
+</pkgmetadata>