summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-haskell/preprocessor-tools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-haskell/preprocessor-tools')
-rw-r--r--dev-haskell/preprocessor-tools/Manifest1
-rw-r--r--dev-haskell/preprocessor-tools/metadata.xml16
-rw-r--r--dev-haskell/preprocessor-tools/preprocessor-tools-1.0.1.ebuild28
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/preprocessor-tools/Manifest b/dev-haskell/preprocessor-tools/Manifest
new file mode 100644
index 000000000000..3814e0becb22
--- /dev/null
+++ b/dev-haskell/preprocessor-tools/Manifest
@@ -0,0 +1 @@
+DIST preprocessor-tools-1.0.1.tar.gz 9895 SHA256 c946c99fe8c9effba27946cd2c26173d2346340528d800a228796d68f8aeee59 SHA512 b039c763eda293950a73c089903bbc2f447b92740077c042a764c2523db581450c96e3fda7ae177336d96626283283843c93006eca73d02951ca9067a3b12665 WHIRLPOOL 5328ef4648f2778a39a089ad40c911203abc037d99a9850165f30225ad189f33a912f4c64087f2e5a5c4cb49a4a0efc587ebcfd72e7346317171c0b6991a124a
diff --git a/dev-haskell/preprocessor-tools/metadata.xml b/dev-haskell/preprocessor-tools/metadata.xml
new file mode 100644
index 000000000000..217bd1b1fb11
--- /dev/null
+++ b/dev-haskell/preprocessor-tools/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <longdescription>
+ This library provides a quick-and-dirty (but often effective)
+ method for extending Haskell&#39;s syntax using a custom
+ preprocessor. It parses Haskell into a bare-bones AST with just
+ enough knowledge of the syntax to preserve nesting, and then
+ allows transformations on the AST.
+
+ See the package ixdopp
+ (&lt;http://hackage.haskell.org/cgi-bin/hackage-scripts/package/ixdopp&gt;)
+ for an example of how to do this.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/preprocessor-tools/preprocessor-tools-1.0.1.ebuild b/dev-haskell/preprocessor-tools/preprocessor-tools-1.0.1.ebuild
new file mode 100644
index 000000000000..f757c5d4cdc1
--- /dev/null
+++ b/dev-haskell/preprocessor-tools/preprocessor-tools-1.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A framework for extending Haskell's syntax via quick-and-dirty preprocessors"
+HOMEPAGE="http://www.eecs.harvard.edu/~tov/pubs/haskell-session-types/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/mtl-1:=[profile?] <dev-haskell/mtl-3:=[profile?]
+ >=dev-haskell/parsec-3:=[profile?] <dev-haskell/parsec-4:=[profile?]
+ >=dev-haskell/syb-0:=[profile?] <dev-haskell/syb-1:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2.3
+"