summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 22:07:55 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 22:16:30 +0000
commit9e500362b1b6703443395aea56ebd23f9cebc21b (patch)
tree548cebf6629a87d6ec4e59dd3e8f5254ca53b6b5 /dev-haskell
parentdev-haskell/gtk3: bump up to 0.14.6 (diff)
downloadgentoo-9e500362b1b6703443395aea56ebd23f9cebc21b.tar.gz
gentoo-9e500362b1b6703443395aea56ebd23f9cebc21b.tar.bz2
gentoo-9e500362b1b6703443395aea56ebd23f9cebc21b.zip
dev-haskell/glade: tweak for ghc-8
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/glade/files/Setup.hs8
-rw-r--r--dev-haskell/glade/glade-0.12.5.0-r100.ebuild43
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-haskell/glade/files/Setup.hs b/dev-haskell/glade/files/Setup.hs
new file mode 100644
index 000000000000..5fbe833309e9
--- /dev/null
+++ b/dev-haskell/glade/files/Setup.hs
@@ -0,0 +1,8 @@
+-- Adjustments specific to this package,
+-- all Gtk2Hs-specific boilerplate is kept in
+-- gtk2hs-buildtools:Gtk2HsSetup
+--
+import Gtk2HsSetup ( gtk2hsUserHooks )
+import Distribution.Simple ( defaultMainWithHooks )
+
+main = defaultMainWithHooks gtk2hsUserHooks
diff --git a/dev-haskell/glade/glade-0.12.5.0-r100.ebuild b/dev-haskell/glade/glade-0.12.5.0-r100.ebuild
new file mode 100644
index 000000000000..3ce300d275b7
--- /dev/null
+++ b/dev-haskell/glade/glade-0.12.5.0-r100.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the glade library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="2/${PV}"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/glib-0.12.5.0:0=[profile?]
+ >=dev-haskell/gtk-0.12.5.0:2=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ gnome-base/libglade:2.0
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/gtk2hs-buildtools-0.12.5.1-r1:0=
+ >=dev-haskell/cabal-1.24
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-ghc-7.10.patch
+
+ # update to latest gtk2hs-buildtools
+ rm Setup.hs || die
+ rm Gtk2HsSetup.hs || die
+ cp "${FILESDIR}"/Setup.hs ./ || die
+
+ cabal_chdeps \
+ 'glib >= 0.12.5.0 && < 0.13' 'glib >= 0.12.5.0' \
+ 'gtk >= 0.12.5.0 && < 0.13' 'gtk >= 0.12.5.0'
+}