summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2018-06-14 12:36:02 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2018-06-14 12:41:03 +0100
commiteabc41f9609968b4b20c140b2e444da166a0e05e (patch)
tree9df251f05d52aeb517e69a17a12d12608aaa6e67 /dev-haskell
parentnet-vpn/tor: version bump to 0.3.4.2_alpha, drop older alpha (diff)
downloadgentoo-eabc41f9609968b4b20c140b2e444da166a0e05e.tar.gz
gentoo-eabc41f9609968b4b20c140b2e444da166a0e05e.tar.bz2
gentoo-eabc41f9609968b4b20c140b2e444da166a0e05e.zip
dev-haskell/megaparsec: allow parser-combinators-1
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/megaparsec/megaparsec-6.5.0-r1.ebuild (renamed from dev-haskell/megaparsec/megaparsec-6.5.0.ebuild)9
1 files changed, 8 insertions, 1 deletions
diff --git a/dev-haskell/megaparsec/megaparsec-6.5.0.ebuild b/dev-haskell/megaparsec/megaparsec-6.5.0-r1.ebuild
index 7435ecb9720..805cfacfc1e 100644
--- a/dev-haskell/megaparsec/megaparsec-6.5.0.ebuild
+++ b/dev-haskell/megaparsec/megaparsec-6.5.0-r1.ebuild
@@ -21,7 +21,7 @@ IUSE=""
RDEPEND=">=dev-haskell/case-insensitive-1.2:=[profile?] <dev-haskell/case-insensitive-1.3:=[profile?]
>=dev-haskell/fail-4.9:=[profile?] <dev-haskell/fail-4.10:=[profile?]
>=dev-haskell/mtl-2.0:=[profile?] <dev-haskell/mtl-3.0:=[profile?]
- >=dev-haskell/parser-combinators-0.4:=[profile?] <dev-haskell/parser-combinators-2.0:=[profile?]
+ >=dev-haskell/parser-combinators-0.4:=[profile?]
>=dev-haskell/scientific-0.3.1:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
>=dev-haskell/semigroups-0.18:=[profile?] <dev-haskell/semigroups-0.19:=[profile?]
>=dev-haskell/text-0.2:=[profile?] <dev-haskell/text-1.3:=[profile?]
@@ -33,6 +33,13 @@ DEPEND="${RDEPEND}
>=dev-haskell/hspec-expectations-0.5 <dev-haskell/hspec-expectations-0.9
>=dev-haskell/quickcheck-2.7 <dev-haskell/quickcheck-2.12 )
"
+src_prepare() {
+ default
+
+ cabal_chdeps \
+ 'parser-combinators >= 0.4 && < 1.0' 'parser-combinators >= 0.4' \
+ 'build-tools: hspec-discover >= 2.0 && < 3.0' 'build-depends: hspec-discover >= 2.0 && < 3.0'
+}
src_configure() {
haskell-cabal_src_configure \