summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/ant-nodeps
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/ant-nodeps')
-rw-r--r--dev-java/ant-nodeps/Manifest2
-rw-r--r--dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild28
-rw-r--r--dev-java/ant-nodeps/metadata.xml5
3 files changed, 35 insertions, 0 deletions
diff --git a/dev-java/ant-nodeps/Manifest b/dev-java/ant-nodeps/Manifest
new file mode 100644
index 000000000000..fc8a10d97263
--- /dev/null
+++ b/dev-java/ant-nodeps/Manifest
@@ -0,0 +1,2 @@
+DIST ant-1.9.2-gentoo.tar.bz2 14884 SHA256 0e2b1888b1f5d840db6d13da833b5289df96076c1d2d6b5497840e74b6cb4bdc SHA512 2bb84e71d1f07fa9341e674164ee680875381a0a52f5309a1a6f4092df691bf9a83955e4b1a9bcc907fbb2f4d4427afa192bffb8909314b8e519f0b76ebf5b7f WHIRLPOOL d91b2c3bbc30a2b395a182a8248785edea8ce9e6734fcaedd715e3a64e967de494ed78370c70d549f8de96e70e61c67fe1f22b56842cfdbfd66a723d2c8f62f8
+DIST apache-ant-1.9.2-src.tar.bz2 3402876 SHA256 cf95317f683f28ae3d263327447abbebd30a6c910cfa069a05c5ee39aa5ad0e3 SHA512 44d37e7b6c22741293ae9d6f331bc5a21a807206d22082b111af95a0d1820b62f806c5ee8d8ac638566b86990ec802bc948066c4ac9da27262659b24545fc629 WHIRLPOOL 94fa5f5f3f2d52ed37efea5b6e6da9ace7a6ddb9e0e9377fd655fe2ead58f707c9a9e461ac4069138bf8af728b9c5c320ac5f969e655f2004dc92ebd62e4ed9d
diff --git a/dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild b/dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild
new file mode 100644
index 000000000000..11093dfac280
--- /dev/null
+++ b/dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+ANT_TASK_DEPNAME=""
+ANT_TASK_DISABLE_VM_DEPS="true"
+
+inherit ant-tasks
+
+DESCRIPTION="Formerly Ant's optional tasks w/o external deps, now compat empty jar"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Dependency needed for jar.
+DEPEND=">=virtual/jdk-1.4"
+
+src_compile() {
+ # The classes were moved to ant-core in 1.8.2, this is just for compatibility.
+ mkdir -p build/lib/empty && cd build/lib/empty || die
+ jar -cf ../${PN}.jar . || die
+}
+
+pkg_postinst() {
+ elog "Upstream has removed ant-nodeps.jar as of 1.8.2 and moved the classes to ant.jar"
+ elog "This package thus installs an empty jar for compatibility"
+ elog "and will be removed once reverse dependencies are transitioned."
+}
diff --git a/dev-java/ant-nodeps/metadata.xml b/dev-java/ant-nodeps/metadata.xml
new file mode 100644
index 000000000000..7303cef96964
--- /dev/null
+++ b/dev-java/ant-nodeps/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+</pkgmetadata>