summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2015-08-10 19:09:54 +0000
committerPatrice Clement <monsieurp@gentoo.org>2015-08-10 19:39:47 +0000
commit1e872fdf461f37b1554bc444acbf34cd84f85660 (patch)
tree96debf0413d624f2d9bbce5b34a22dff25888c42 /dev-java/bcpg
parentdev-java/ant-ivy: Update dev-java/bcprov dependency to match with new SLOT (diff)
downloadgentoo-1e872fdf461f37b1554bc444acbf34cd84f85660.tar.gz
gentoo-1e872fdf461f37b1554bc444acbf34cd84f85660.tar.bz2
gentoo-1e872fdf461f37b1554bc444acbf34cd84f85660.zip
dev-java/bcpg: Drop old.
Package-Manager: portage-2.2.18 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-java/bcpg')
-rw-r--r--dev-java/bcpg/bcpg-1.50.ebuild85
-rw-r--r--dev-java/bcpg/bcpg-1.52.ebuild87
2 files changed, 0 insertions, 172 deletions
diff --git a/dev-java/bcpg/bcpg-1.50.ebuild b/dev-java/bcpg/bcpg-1.50.ebuild
deleted file mode 100644
index 0d1560abd9a9..000000000000
--- a/dev-java/bcpg/bcpg-1.50.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-MY_P="${PN}-jdk15on-${PV/./}"
-
-DESCRIPTION="Java cryptography APIs"
-HOMEPAGE="http://www.bouncycastle.org/java.html"
-SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
-
-# Tests are currently broken. Appears to need older version of bcprov; but since bcprov is not slotted, this can cause conflicts.
-# Needs further investigation; though, only a small part has tests and there are no tests for bcpg itself.
-RESTRICT="test"
-
-COMMON_DEPEND="
- >=dev-java/bcprov-${PV}:0[test?]"
-
-DEPEND=">=virtual/jdk-1.5
- app-arch/unzip
- test? ( dev-java/junit:0 )
- ${COMMON_DEPEND}"
-
-RDEPEND=">=virtual/jre-1.5
- ${COMMON_DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- default
- cd "${S}"
- unpack ./src.zip
-}
-
-java_prepare() {
- mkdir "${S}"/classes
-
- if use test ; then
- java-pkg_jar-from --build-only junit
- fi
-
- java-pkg_jar-from bcprov
-}
-
-src_compile() {
- find org -name "*.java" > "${T}"/src.list
-
- local cp="bcprov.jar"
- if use test ; then
- cp="${cp}:junit.jar"
- else
- sed -i '/\/test\//d' "${T}"/src.list || die "Failed to remove test classes"
- fi
-
- ejavac -d "${S}"/classes -cp ${cp} "@${T}"/src.list
-
- cd "${S}"/classes || die
-
- jar -cf "${S}"/${PN}.jar * || die "Failed to create jar."
-}
-
-src_test() {
- local cp="${PN}.jar:bcprov.jar:junit.jar"
- local pkg="org.bouncycastle"
-
- java -cp ${cp} ${pkg}.openpgp.test.AllTests | tee openpgp.tests
-
- grep -q FAILURES *.tests && die "Tests failed."
-}
-
-src_install() {
- java-pkg_dojar "${S}"/${PN}.jar
-
- use source && java-pkg_dosrc org
- use doc && java-pkg_dojavadoc docs
-}
diff --git a/dev-java/bcpg/bcpg-1.52.ebuild b/dev-java/bcpg/bcpg-1.52.ebuild
deleted file mode 100644
index d2d42daa186d..000000000000
--- a/dev-java/bcpg/bcpg-1.52.ebuild
+++ /dev/null
@@ -1,87 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-JAVA_PKG_IUSE="doc source test"
-
-inherit java-pkg-2 java-ant-2
-
-MY_P="${PN}-jdk15on-${PV/./}"
-
-DESCRIPTION="Java cryptography APIs"
-HOMEPAGE="http://www.bouncycastle.org/java.html"
-SRC_URI="http://www.bouncycastle.org/download/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-macos"
-
-# Tests are currently broken. Appears to need older version of bcprov; but since bcprov is not slotted, this can cause conflicts.
-# Needs further investigation; though, only a small part has tests and there are no tests for bcpg itself.
-RESTRICT="test"
-
-CDEPEND="
- >=dev-java/bcprov-${PV}:0[test?]"
-
-DEPEND=">=virtual/jdk-1.6
- app-arch/unzip
- test? (
- dev-java/junit:0
- )
- ${CDEPEND}"
-
-RDEPEND=">=virtual/jre-1.6
- ${CDEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-src_unpack() {
- default
- cd "${S}"
- unpack ./src.zip
-}
-
-java_prepare() {
- mkdir "${S}"/classes
-
- if use test; then
- java-pkg_jar-from --build-only junit
- fi
-
- java-pkg_jar-from bcprov
-}
-
-src_compile() {
- find org -name "*.java" > "${T}"/src.list
-
- local cp="bcprov.jar"
- if use test ; then
- cp="${cp}:junit.jar"
- else
- sed -i '/\/test\//d' "${T}"/src.list || die "Failed to remove test classes"
- fi
-
- ejavac -d "${S}"/classes -cp ${cp} "@${T}"/src.list
-
- cd "${S}"/classes || die
-
- jar -cf "${S}"/${PN}.jar * || die "Failed to create jar."
-}
-
-src_test() {
- local cp="${PN}.jar:bcprov.jar:junit.jar"
- local pkg="org.bouncycastle"
-
- java -cp ${cp} ${pkg}.openpgp.test.AllTests | tee openpgp.tests
-
- grep -q FAILURES *.tests && die "Tests failed."
-}
-
-src_install() {
- java-pkg_dojar "${S}"/${PN}.jar
-
- use source && java-pkg_dosrc org
- use doc && java-pkg_dojavadoc docs
-}