summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/commons-io
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/commons-io')
-rw-r--r--dev-java/commons-io/Manifest2
-rw-r--r--dev-java/commons-io/commons-io-2.0.1.ebuild57
-rw-r--r--dev-java/commons-io/commons-io-2.4.ebuild57
-rw-r--r--dev-java/commons-io/metadata.xml5
4 files changed, 121 insertions, 0 deletions
diff --git a/dev-java/commons-io/Manifest b/dev-java/commons-io/Manifest
new file mode 100644
index 000000000000..faeff6ca9739
--- /dev/null
+++ b/dev-java/commons-io/Manifest
@@ -0,0 +1,2 @@
+DIST commons-io-2.0.1-src.tar.gz 280920 SHA256 32be3e626618b49c2e2fb268bd2101d7ae38438131df4560fc800bd2f26fdff8 SHA512 0e01d12c46707ff254b8aa3b31fe8d027e7bafd34a2c2c96b8867084bbe43c763d03f773189ec17ffc6525ad8d022009cb64cdf288a401194e8c0ebbe5d99ee2 WHIRLPOOL 4e34102bdf9b025165f25d09287ce446f838a92c990db099f5a9356cad994b88b9916c089f2ffcb7ceeeb5250b22daace637b7df5a3526711923824d0dc3f8f1
+DIST commons-io-2.4-src.tar.gz 330961 SHA256 961c8b41a891933c2d662d8e490667243ac82422668d1ccdd7bfedfdb944bb58 SHA512 69ac5f7b8de952d8b519ad89d4e9a33a9d269af0e68b735c0180ee8853a30e2a09147ceac362626a2fb3a041bd46eca094be2661ff280c1bab54a0548cae0aee WHIRLPOOL 4db6be6dbba4e3c9f67c471eff709ade22594ef1cea759da5651fa5788b1bcfeca689621eb3ff7ca52dca0229b096d597e9f5cb969ebcc7a06ff18f28ccc3551
diff --git a/dev-java/commons-io/commons-io-2.0.1.ebuild b/dev-java/commons-io/commons-io-2.0.1.ebuild
new file mode 100644
index 000000000000..13f5365330b9
--- /dev/null
+++ b/dev-java/commons-io/commons-io-2.0.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_P="${P}-src"
+DESCRIPTION="Commons-IO contains utility classes, stream implementations, file filters, and endian classes"
+HOMEPAGE="http://commons.apache.org/io/"
+SRC_URI="mirror://apache/commons/io/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+DEPEND=">=virtual/jdk-1.5
+ test? ( dev-java/ant-junit )"
+RDEPEND=">=virtual/jre-1.5"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ java-ant_ignore-system-classes
+ java-ant_rewrite-classpath
+ # Setting java.io.tmpdir doesn't have effect unless we do this because the
+ # vm is forked
+ java-ant_xml-rewrite -f build.xml --change -e junit -a clonevm -v "true"
+}
+
+EANT_EXTRA_ARGS="-Duser.home=${T}"
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]]; then
+ ANT_OPTS="-Djava.io.tmpdir=${T} -Duser.home=${T}" \
+ ANT_TASKS="ant-junit" \
+ eant test \
+ -Dgentoo.classpath="$(java-pkg_getjars junit)" \
+ -Dlibdir="libdir" \
+ -Djava.io.tmpdir="${T}"
+ else
+ elog "Tests fail unless userpriv is enabled because they test for"
+ elog "file permissions which doesn't work when run as root."
+ fi
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar ${PN}.jar
+
+ dodoc RELEASE-NOTES.txt NOTICE.txt || die
+ use doc && java-pkg_dojavadoc target/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/commons-io/commons-io-2.4.ebuild b/dev-java/commons-io/commons-io-2.4.ebuild
new file mode 100644
index 000000000000..ff7b7e00d683
--- /dev/null
+++ b/dev-java/commons-io/commons-io-2.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-ant-2 eutils
+
+MY_P=${P}-src
+DESCRIPTION="Commons-IO contains utility classes, stream implementations, file filters, and endian classes"
+HOMEPAGE="http://commons.apache.org/io/"
+SRC_URI="mirror://apache/commons/io/source/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="1"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=virtual/jre-1.6"
+DEPEND=">=virtual/jdk-1.6
+ test? (
+ dev-java/ant-junit:0
+ dev-java/junit:4
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+EANT_EXTRA_ARGS="-Dcomponent.version=${PV}"
+JAVA_ANT_REWRITE_CLASSPATH="yes"
+
+java_prepare() {
+ # Setting java.io.tmpdir doesn't have effect unless we do this because the vm is forked
+ java-ant_xml-rewrite -f build.xml --change -e junit -a clonevm -v "true"
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]] ; then
+ ANT_OPTS="-Dskip.download=1 -Djava.io.tmpdir=${T} -Duser.home=${T}" \
+ ANT_TASKS="ant-junit" \
+ eant test \
+ -Dgentoo.classpath="$(java-pkg_getjars junit-4):${S}/src/test/resources" \
+ -Dlibdir="libdir" \
+ -Djava.io.tmpdir="${T}"
+ else
+ elog "Tests fail unless userpriv is enabled because they test for"
+ elog "file permissions which doesn't work when run as root."
+ fi
+}
+
+src_install() {
+ java-pkg_newjar target/${P}.jar
+
+ dodoc RELEASE-NOTES.txt
+ use doc && java-pkg_dojavadoc target/apidocs
+ use source && java-pkg_dosrc src/main/java/*
+}
diff --git a/dev-java/commons-io/metadata.xml b/dev-java/commons-io/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/commons-io/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>