summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jboss-modules
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jboss-modules')
-rw-r--r--dev-java/jboss-modules/Manifest2
-rw-r--r--dev-java/jboss-modules/jboss-modules-1.3.0.ebuild31
-rw-r--r--dev-java/jboss-modules/jboss-modules-1.3.3.ebuild31
-rw-r--r--dev-java/jboss-modules/metadata.xml9
4 files changed, 73 insertions, 0 deletions
diff --git a/dev-java/jboss-modules/Manifest b/dev-java/jboss-modules/Manifest
new file mode 100644
index 000000000000..9f917de4330f
--- /dev/null
+++ b/dev-java/jboss-modules/Manifest
@@ -0,0 +1,2 @@
+DIST jboss-modules-1.3.0.tar.gz 187838 SHA256 d30783899f3399ff69d8a0bb86702a5788d68d3c24b25095dbff19ca17fdea73 SHA512 407858cec3a82ad81262ef1feb28e3c3c259b23f3ed768f8714b28dcb8e2cc6bd68a47f82c8422d2c40ee9d0777a14c968c432a5f10f852bbd08ae434e249e56 WHIRLPOOL c205a754943bf19631de1a5accd20c17f1c6f9813f6abbb0d1ae0282d3c83365a17900477daadfe1c0085ddabc1f6b7d56d5dd475e4991fada96c386b4e2d31c
+DIST jboss-modules-1.3.3.tar.gz 189899 SHA256 ed288523f78ce3ea529114aeed35fee2e2e9c30e90126d0efe50168df5a8ca4f SHA512 2d95d8f2661250fe3458feed9d1edc810abc5741ef0b631336927817820ec92b8f5b4ee0a329392c6ad82c68f67c5f831b294ca44dbf66bb9ca866e8ad70b535 WHIRLPOOL 3a0d04e2416bd75eff19a4784afebdf564cecffa9b19e2379a2729c90fc427592b54a7dd2a422243df0e7baf4e9133f037ba36ac9b18cce1206b9c8f96b15a5e
diff --git a/dev-java/jboss-modules/jboss-modules-1.3.0.ebuild b/dev-java/jboss-modules/jboss-modules-1.3.0.ebuild
new file mode 100644
index 000000000000..4e601b3375dc
--- /dev/null
+++ b/dev-java/jboss-modules/jboss-modules-1.3.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JBoss modular classloading system"
+HOMEPAGE="http://www.jboss.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.Final.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.7"
+DEPEND=">=virtual/jdk-1.7"
+
+S="${WORKDIR}/${P}.Final/"
+
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ rm pom.xml || die
+ mkdir -p target/classes || die
+ cp -vr "${S}"/src/main/resources/* target/classes/ || die
+}
diff --git a/dev-java/jboss-modules/jboss-modules-1.3.3.ebuild b/dev-java/jboss-modules/jboss-modules-1.3.3.ebuild
new file mode 100644
index 000000000000..b655dfc7ae6a
--- /dev/null
+++ b/dev-java/jboss-modules/jboss-modules-1.3.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source" # doc (needs APIviz)
+
+inherit java-pkg-2 java-pkg-simple
+
+DESCRIPTION="JBoss modular classloading system"
+HOMEPAGE="http://www.jboss.org/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.Final.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.7"
+DEPEND=">=virtual/jdk-1.7"
+
+S="${WORKDIR}/${P}.Final/"
+
+JAVA_SRC_DIR="src/main/java"
+
+java_prepare() {
+ rm pom.xml || die
+ mkdir -p target/classes || die
+ cp -vr "${S}"/src/main/resources/* target/classes/ || die
+}
diff --git a/dev-java/jboss-modules/metadata.xml b/dev-java/jboss-modules/metadata.xml
new file mode 100644
index 000000000000..6a960ae0c94e
--- /dev/null
+++ b/dev-java/jboss-modules/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="github">jboss-modules/jboss-modules</remote-id>
+ </upstream>
+</pkgmetadata>
+