summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-java/jdbm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-java/jdbm')
-rw-r--r--dev-java/jdbm/Manifest1
-rw-r--r--dev-java/jdbm/files/jdbm-0.12-buildfile.patch53
-rw-r--r--dev-java/jdbm/jdbm-0.12-r2.ebuild43
-rw-r--r--dev-java/jdbm/metadata.xml8
4 files changed, 105 insertions, 0 deletions
diff --git a/dev-java/jdbm/Manifest b/dev-java/jdbm/Manifest
new file mode 100644
index 000000000000..a39f418caae9
--- /dev/null
+++ b/dev-java/jdbm/Manifest
@@ -0,0 +1 @@
+DIST jdbm-0.12-src.zip 969490 SHA256 ec431becfd915f4908e5e3f71dc13b05310890ac2ad1664e508a9890151ea10a SHA512 cf65a89d1b3262aba40a2b10cdf3bbc1ed75fd60facfbd22baad2cfbcf81b5d67d3b7a372c7018907eedbcbb0114ddbb8d13b6cb7bc47896c47997996b0d57ec WHIRLPOOL 2504311219194c370509f91bad895d2b8818221f3d1ad454936484cd63fa028958d0c1e92c322bfefafff6a017a441ecaf952a151b5947fca73ddb922d717b51
diff --git a/dev-java/jdbm/files/jdbm-0.12-buildfile.patch b/dev-java/jdbm/files/jdbm-0.12-buildfile.patch
new file mode 100644
index 000000000000..23957e131c50
--- /dev/null
+++ b/dev-java/jdbm/files/jdbm-0.12-buildfile.patch
@@ -0,0 +1,53 @@
+--- build.xml.orig 2005-02-05 23:34:43.000000000 +0100
++++ build.xml 2005-02-06 00:02:39.392389088 +0100
+@@ -1,9 +1,9 @@
+-<project name="JDBM" default="main" basedir=".">
++<project name="JDBM" default="main" basedir="..">
+
+ <target name="init">
+ <property name="project" value="jdbm" />
+ <property name="source" value="./src" />
+- <property name="main" value="${source}/main" />
++ <property name="main.src" value="${source}/main" />
+ <property name="etc" value="${source}/etc" />
+ <property name="build" value="build" />
+ <property name="classes" value="${build}/classes" />
+@@ -16,7 +16,7 @@
+ <property name="build.compiler" value="classic" />
+ <property name="deprecation" value="true" />
+ <property file="VERSION" />
+- <property name="archive" value="${project}-${version}" />
++ <property name="archive" value="${project}" />
+ </target>
+
+
+@@ -46,7 +46,7 @@
+
+
+ <!-- Prepare target directories -->
+- <target name="prepare">
++ <target name="prepare" depends="init">
+ <mkdir dir="${build}"/>
+ <mkdir dir="${classes}"/>
+ <mkdir dir="${dist}"/>
+@@ -61,8 +61,9 @@
+
+ <!-- Build all the sources with debug and deprecation -->
+ <target name="main" depends="prepare">
+- <javac srcdir="${main}" destdir="${classes}" excludes="**/package.html"
+- classpath="${classpath}" debug="on" deprecation="${deprecation}" />
++ <javac srcdir="${source}/main" destdir="${classes}" excludes="**/package.html"
++ classpath="${classpath}" debug="on" deprecation="${deprecation}"
++ target="1.3" source="1.3" />
+ </target>
+
+ <!-- Same as main, but also cleans and additional targets -->
+@@ -131,7 +132,7 @@
+ <mkdir dir="${build}/doc/javadoc" />
+ <property name="copyright"
+ value="Cees de Groot (C) 2000-2001. All rights reserved http://jdbm.sourceforge.net" />
+- <javadoc sourcepath="${main}" destdir="${build}/doc/javadoc" dir="."
++ <javadoc sourcepath="${source}/main" destdir="${build}/doc/javadoc"
+ doctitle="JDBM JavaDoc" windowtitle="JDBM JavaDoc" bottom="${copyright}"
+ package="true" author="true" version="true" noindex="true"
+ packagenames="jdbm.*" />
diff --git a/dev-java/jdbm/jdbm-0.12-r2.ebuild b/dev-java/jdbm/jdbm-0.12-r2.ebuild
new file mode 100644
index 000000000000..c93a9f49cfcb
--- /dev/null
+++ b/dev-java/jdbm/jdbm-0.12-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+JAVA_PKG_IUSE="doc source"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="Jdbm aims to be for Java what GDBM is for Perl, Python, C, ..."
+HOMEPAGE="http://jdbm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+
+LICENSE="BSD"
+SLOT="1"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+# Needs to depend on 1.3 because this uses assert
+# so we need -source 1.3 here.
+RDEPEND=">=virtual/jre-1.3"
+DEPEND=">=virtual/jdk-1.3
+ app-arch/unzip"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}/src"
+ epatch "${FILESDIR}/${P}-buildfile.patch"
+
+ cd "${S}/lib"
+ rm -v *.jar || die
+}
+
+src_compile() {
+ cd "${S}/src"
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ use doc && java-pkg_dojavadoc build/doc/javadoc
+ use source && java-pkg_dosrc src/main/*
+}
diff --git a/dev-java/jdbm/metadata.xml b/dev-java/jdbm/metadata.xml
new file mode 100644
index 000000000000..47a0ce099855
--- /dev/null
+++ b/dev-java/jdbm/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>java</herd>
+ <upstream>
+ <remote-id type="sourceforge">jdbm</remote-id>
+ </upstream>
+</pkgmetadata>